aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cpputest
diff options
context:
space:
mode:
authorShiva <shiv@shiv.me>2017-01-01 23:47:09 -0800
committerJakub Jirutka <jakub@jirutka.cz>2017-02-06 16:58:15 +0100
commit6e505abcd5171af03bd65cd0c7c8dd0b6a9c16b9 (patch)
treea7d5e657ac3a76ef7de5c150a69a59d678773b69 /testing/cpputest
parent05c4b90783a66b036056239eca0ae6fa599046c2 (diff)
downloadaports-6e505abcd5171af03bd65cd0c7c8dd0b6a9c16b9.tar.bz2
aports-6e505abcd5171af03bd65cd0c7c8dd0b6a9c16b9.tar.xz
testing/cpputest: new aport
http://cpputest.github.io/ A unit testing and mocking framework for C/C++ Review notes: I've cleaned apkbuild a bit and moved /usr/lib/CppUTest/cmake to /usr/lib/cmake/CppUTest. ~ @jirutka
Diffstat (limited to 'testing/cpputest')
-rw-r--r--testing/cpputest/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/cpputest/APKBUILD b/testing/cpputest/APKBUILD
new file mode 100644
index 0000000000..8f56f3eb46
--- /dev/null
+++ b/testing/cpputest/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Shiva Velmurugan <shiv@shiv.me>
+# Maintainer: Shiva Velmurugan <shiv@shiv.me>
+pkgname=cpputest
+pkgver=3.8
+pkgrel=0
+pkgdesc="A unit testing and mocking framework for C/C++"
+url="http://cpputest.github.io/"
+arch="all"
+license="BSD"
+makedepends="cmake"
+subpackages="$pkgname-doc"
+source="https://github.com/cpputest/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ mkdir -p "$builddir"/build
+ cd "$builddir"/build
+
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"/build
+
+ make DESTDIR="$pkgdir" install || return 1
+
+ mkdir -p "$pkgdir"/usr/lib/cmake
+ mv "$pkgdir"/usr/lib/CppUTest/cmake \
+ "$pkgdir"/usr/lib/cmake/CppUTest || return 1
+ rmdir "$pkgdir"/usr/lib/CppUTest || true
+
+ install -Dm644 ../COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+md5sums="e8fdbbb5dd37d32d65919f240f984905 cpputest-3.8.tar.gz"
+sha256sums="c81dccc5a1bfc7fc6511590c0a61def5f78e3fb19cb8e1f889d8d3395a476456 cpputest-3.8.tar.gz"
+sha512sums="a9592bdc9ffab8b42026ef2010f504e7e37d77fc2f197f89d23f7c9285a101059a0ec66418b914db0383974616d31b26addd1938fb27f45c3e7d9496ed0a0fac cpputest-3.8.tar.gz"