aboutsummaryrefslogtreecommitdiffstats
path: root/testing/criu
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-12-30 12:12:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-01-02 16:34:11 +0000
commitcaeb86da6b902a3cb713e66f9de64d486c3bdb1f (patch)
tree5f1dc04907d2056cf87dab09eefacfb1f78824fb /testing/criu
parentf9c421d60809483251cc373c762e0a8293ee697b (diff)
downloadaports-caeb86da6b902a3cb713e66f9de64d486c3bdb1f.tar.bz2
aports-caeb86da6b902a3cb713e66f9de64d486c3bdb1f.tar.xz
testing/criu: upgrade to 3.7
Diffstat (limited to 'testing/criu')
-rw-r--r--testing/criu/APKBUILD33
-rw-r--r--testing/criu/fix-wait.h.patch55
-rw-r--r--testing/criu/unknown-type__uid_t.patch10
3 files changed, 14 insertions, 84 deletions
diff --git a/testing/criu/APKBUILD b/testing/criu/APKBUILD
index 72bd53f1c9..25f258e619 100644
--- a/testing/criu/APKBUILD
+++ b/testing/criu/APKBUILD
@@ -1,19 +1,18 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=criu
-pkgver=2.9
-pkgrel=2
+pkgver=3.7
+pkgrel=0
pkgdesc="A Checkpoint/Restore utility for Linux in Userspace"
url="http://criu.org"
arch="x86_64"
license="GPL-2.0"
makedepends="xmlto asciidoc python protobuf-c-dev protobuf-dev libaio-dev libnl3-dev
- py-protobuf libcap-dev perl"
+ py-protobuf libcap-dev perl libnet-dev"
+checkdepends="py-yaml"
+options="!check" # https://github.com/checkpoint-restore/criu/issues/434
subpackages="$pkgname-dev $pkgname-doc py-$pkgname:_py:noarch"
-source="$pkgname-$pkgver.tar.gz::https://github.com/xemul/$pkgname/archive/v$pkgver.tar.gz
- unknown-type__uid_t.patch
- fix-wait.h.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/xemul/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/"$pkgname-$pkgver
build() {
@@ -23,11 +22,15 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
- make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
- rm "$pkgdir"/usr/libexec/criu/scripts/systemd-autofs-restart.sh || return 1
- find "$pkgdir"/usr/libexec -type d -delete
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/libexec/criu/scripts/systemd-autofs-restart.sh
}
_py() {
@@ -37,12 +40,4 @@ _py() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-md5sums="b4ae4ddaf17a17d56ac1f5bf84256d05 criu-2.9.tar.gz
-94e0c93b6c82d4e9e26a64da6ed4e6d9 unknown-type__uid_t.patch
-50a7fa53171d082bdbc2558d5c0cec9e fix-wait.h.patch"
-sha256sums="0be28da3a34c7152a8d54eef1fb0b8031dc067f7af59af96730548b82137a130 criu-2.9.tar.gz
-703ce29be3324b92b2118482da17656bd691d844f787e50ec9a3c379827d81ad unknown-type__uid_t.patch
-75f2d549250d4eddb17db92c8c2c63cbe125d27058b51665184c5536bf3a783e fix-wait.h.patch"
-sha512sums="5999764a163a51f0accb0aeb6292e501815a4a252246855e2a0702fea030c169953bcce3912b746d4849955022a6d145065762ff19edcfe2768ecfa699b95b61 criu-2.9.tar.gz
-a9abac887a453b5265f18ebd75432eecfd1a1be18b43078651163789ebea76f2d155ff4574bc43d9d025d6bd3360a053aee0a73bf5dcc319294e8138ee514019 unknown-type__uid_t.patch
-c35ae61b7bd20b2205949213d5a54a5a31e7aab6eaed5f9afa00dad6ab0fa8007cae25f4cda89957b5535f3073487a854169b09eda3ee48ab6d9af8ce055d991 fix-wait.h.patch"
+sha512sums="a41bc3bdf26013b6fc6c5af2b069f7f26bed877a2cfb114fa44590c1255cd2fc5c81aba2ec83c807d55178791b7b4dcf27e14746bcb70fdb4bf00a8ebf865ae7 criu-3.7.tar.gz"
diff --git a/testing/criu/fix-wait.h.patch b/testing/criu/fix-wait.h.patch
deleted file mode 100644
index 2bc3601aa6..0000000000
--- a/testing/criu/fix-wait.h.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- criu-2.6/test/zdtm/static/socket6_udp.c
-+++ criu-2.6/test/zdtm.new/static/socket6_udp.c
-@@ -13,7 +13,7 @@
- #include <stdlib.h>
- #include <sys/socket.h>
- #include <arpa/inet.h> /* for sockaddr_in and inet_ntoa() */
--#include <wait.h>
-+#include <sys/wait.h>
-
- static int port = 8880;
- static char buf[64];
---- criu-2.6/test/zdtm/static/socket_aio.c
-+++ criu-2.6/test/zdtm.new/static/socket_aio.c
-@@ -16,7 +16,7 @@
- #include <errno.h>
- #include <stdlib.h>
- #include <aio.h>
--#include <wait.h>
-+#include <sys/wait.h>
- #include <netinet/tcp.h>
-
- static int port = 8880;
---- criu-2.6/test/zdtm/static/socket_listen.c
-+++ criu-2.6/test/zdtm.new/static/socket_listen.c
-@@ -19,7 +19,7 @@
- #include <unistd.h>
- #include <errno.h>
- #include <stdlib.h>
--#include <wait.h>
-+#include <sys/wait.h>
- #include <netinet/tcp.h>
-
- static int port = 8880;
---- criu-2.6/test/zdtm/static/socket_udp.c
-+++ criu-2.6/test/zdtm.new/static/socket_udp.c
-@@ -18,7 +18,7 @@
- #include <stdlib.h>
- #include <sys/socket.h>
- #include <arpa/inet.h> /* for sockaddr_in and inet_ntoa() */
--#include <wait.h>
-+#include <sys/wait.h>
-
- static int port = 8880;
- static char buf[8];
---- criu-2.6/test/zdtm/static/socket_udplite.c
-+++ criu-2.6/test/zdtm.new/static/socket_udplite.c
-@@ -18,7 +18,7 @@
- #include <stdlib.h>
- #include <sys/socket.h>
- #include <arpa/inet.h> /* for sockaddr_in and inet_ntoa() */
--#include <wait.h>
-+#include <sys/wait.h>
-
- static int port = 8890;
- static char buf[8];
diff --git a/testing/criu/unknown-type__uid_t.patch b/testing/criu/unknown-type__uid_t.patch
deleted file mode 100644
index ff4879e69f..0000000000
--- a/testing/criu/unknown-type__uid_t.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- criu-2.6/test/zdtm/static/pid00.c
-+++ criu-2.6/test/zdtm/static/pid00.c.new
-@@ -1,4 +1,7 @@
- #define _GNU_SOURCE
-+#ifndef __GLIBC__
-+ typedef unsigned int __uid_t;
-+#endif
- #include <errno.h>
- #include <unistd.h>
- #include <sys/types.h>