aboutsummaryrefslogtreecommitdiffstats
path: root/testing/csync2/APKBUILD
diff options
context:
space:
mode:
authorPablo Castorino <pcastorino@mendoza-conicet.gob.ar>2010-11-12 13:45:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-11-13 14:50:46 +0000
commit8663c11aac12a37145e00262d370d946e88065d6 (patch)
treef2ddbe6ba897ba5d41bc0ccdfefe57aa1a8599ed /testing/csync2/APKBUILD
parent42d434f386af7bc200d41ecd602afb065b018290 (diff)
downloadaports-8663c11aac12a37145e00262d370d946e88065d6.tar.bz2
aports-8663c11aac12a37145e00262d370d946e88065d6.tar.xz
testing/csync2: new aport
Diffstat (limited to 'testing/csync2/APKBUILD')
-rw-r--r--testing/csync2/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/csync2/APKBUILD b/testing/csync2/APKBUILD
new file mode 100644
index 0000000000..6c4096a632
--- /dev/null
+++ b/testing/csync2/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=csync2
+pkgver=1.34
+pkgrel=0
+pkgdesc="a cluster synchronization tool"
+url="http://oss.linbit.com/csync2/"
+license="GPL-2+"
+depends=
+makedepends="librsync-dev gnutls-dev sqlite-dev autoconf automake"
+install=
+subpackages="$pkgname-doc"
+source="http://oss.linbit.com/csync2/csync2-$pkgver.tar.gz
+ 01-csync2-sqlite3.patch
+ 02-csync2-1.34-gnutls_pkgconfig.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in ../*.patch; do
+ msg "Applying $i"
+ patch -p1 -i $i || return 1
+ done
+ autoreconf --install --force
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="efc8a3548996b79cef2ad76af5e93cd8 csync2-1.34.tar.gz
+35ba1bb1aafd87741c7ef55bdfb2e212 01-csync2-sqlite3.patch
+31b2ed6a7bb424ccdbf1486223eca323 02-csync2-1.34-gnutls_pkgconfig.patch"