aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ctop
diff options
context:
space:
mode:
authorShyam Sunder <sgsunder1@gmail.com>2019-07-09 23:17:54 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-07-11 18:15:21 -0300
commit54a5451c04fc7bd287dc8e2eddb42e76d66531cb (patch)
tree97efc2a97ac85567897c625e42654e6990f9b646 /testing/ctop
parente85b85773ea6450a6c008a8258b5d6a910b62391 (diff)
downloadaports-54a5451c04fc7bd287dc8e2eddb42e76d66531cb.tar.bz2
aports-54a5451c04fc7bd287dc8e2eddb42e76d66531cb.tar.xz
testing/ctop: new aport
https://ctop.sh/ Top-like interface for container metrics
Diffstat (limited to 'testing/ctop')
-rw-r--r--testing/ctop/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/ctop/APKBUILD b/testing/ctop/APKBUILD
new file mode 100644
index 0000000000..e6893ce6a3
--- /dev/null
+++ b/testing/ctop/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Shyam Sunder <sgsunder1@gmail.com>
+# Maintainer: Shyam Sunder <sgsunder1@gmail.com>
+pkgname=ctop
+pkgver=0.7.2
+pkgrel=0
+pkgdesc="Top-like interface for container metrics"
+url="https://ctop.sh/"
+arch="all"
+license="MIT"
+depends="docker"
+makedepends="go dep"
+options="!check" # No test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/bcicen/$pkgname/archive/v$pkgver.tar.gz"
+
+build() {
+ make build
+}
+
+package() {
+ install -Dm755 "$builddir"/ctop \
+ "$pkgdir"/usr/bin/ctop
+}
+
+sha512sums="d5ef30800534b85b41215170f588cf2ad6460fb7a3fb1d1921ff1f8a7e6c515c76cdb2a089da1ae91067b3893e8a83fcea5616c2ace372bca2394dd57e22c887 ctop-0.7.2.tar.gz"