aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cuetools
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-11-03 10:41:06 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-03 11:51:14 -0300
commit7d22789fc3d90946ef9dea35220c21e58d5629e7 (patch)
treead59a6cf6bfe1a2fd3540c35600b2886ddb2ef59 /testing/cuetools
parent2515332fb393ab55c255b5a8cd10cbe4ee4c2188 (diff)
downloadaports-7d22789fc3d90946ef9dea35220c21e58d5629e7.tar.bz2
aports-7d22789fc3d90946ef9dea35220c21e58d5629e7.tar.xz
testing/cuetools: new aport
Diffstat (limited to 'testing/cuetools')
-rw-r--r--testing/cuetools/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/cuetools/APKBUILD b/testing/cuetools/APKBUILD
new file mode 100644
index 0000000000..7ab1c32d45
--- /dev/null
+++ b/testing/cuetools/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=cuetools
+pkgver=1.4.1
+pkgrel=0
+pkgdesc="cuetools is a set of utilities for working with cue files and toc files"
+url="https://github.com/svend/cuetools"
+arch="all"
+license="GPL-2.0-only"
+makedepends="autoconf automake libtool bison flex"
+options="!check" # no tests
+subpackages="$pkgname-doc"
+source="cuetools-$pkgver.tar.gz::https://github.com/svend/cuetools/archive/$pkgver.tar.gz"
+
+prepare() {
+ autoreconf -fi
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="dc81e6ec756f9d040dd913e8f340be136d68619caa24bdec21364f94b4fc0ffcbcf21325c7fd53c9230d6d70a2856b45a32c5ca7f41ec76fa47298bf226d959e cuetools-1.4.1.tar.gz"