aboutsummaryrefslogtreecommitdiffstats
path: root/testing/curlftpfs/APKBUILD
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2018-12-11 19:08:00 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 08:28:58 +0000
commitf04039399781204786e376f730b8849aea59dcd2 (patch)
tree9b8a9c3a0e690d8ae57888e8f7c054c4c50301c4 /testing/curlftpfs/APKBUILD
parent20380256b171efa7c66a16fbf75d842922e46f27 (diff)
downloadaports-f04039399781204786e376f730b8849aea59dcd2.tar.bz2
aports-f04039399781204786e376f730b8849aea59dcd2.tar.xz
testing/curlftpfs: new aport
Diffstat (limited to 'testing/curlftpfs/APKBUILD')
-rw-r--r--testing/curlftpfs/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/curlftpfs/APKBUILD b/testing/curlftpfs/APKBUILD
new file mode 100644
index 0000000000..1e13c16969
--- /dev/null
+++ b/testing/curlftpfs/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=curlftpfs
+pkgver=0.9.2
+pkgrel=0
+pkgdesc="Fuse mount FTP server"
+url="https://sourceforge.net/projects/curlftpfs/"
+arch="all"
+license="GPL-2.0-only"
+depends="libcurl glib"
+makedepends="curl-dev glib-dev fuse-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://downloads.sourceforge.net/project/curlftpfs/curlftpfs/0.9.2/curlftpfs-0.9.2.tar.gz
+ 001-uclibc_mod.patch
+ 500-fix-CURLOPT_INFILESIZE.patch
+ 510-free_ftpfs_file-memleak-fix.patch
+ 520-nocache-memleak-fix.patch
+ 530-curlftpfs__no_verify_hostname.patch
+ 540-consistent-feature-flag.patch
+ 550-getpass-prototype.patch
+ "
+builddir="$srcdir/${pkgname}-${pkgver}"
+patch_args="-p1"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make CFLAGS="-I/usr/include/fuse -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -D__off_t=off_t -D_FILE_OFFSET_BITS=64"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="df07c418d175f766c89525017fc56e79726061eee0c3a6607ded0e1bf24f64f1475ba0e546157b65892194e3c4414c120822bf8fb175437e68366f82de216067 curlftpfs-0.9.2.tar.gz
+a5705945c04382db2f82b6f8c34e9367b6ee3d442d11744403c78f7a9236d5117fbb0a94824dc5c5572bcda701104f2769264764ab4b5d24017ff58f6a3fa3d1 001-uclibc_mod.patch
+ee0055cb2271da9ed5251800a4d0a7bc64b68482d6f221127d1dbe3df6bdda22a45a9e9ea7f0c938d1eac484a86920c9a76dbd160deb87f78da1515373309f57 500-fix-CURLOPT_INFILESIZE.patch
+e37011cfcb60004d68a4cb76da3a811349166063057e7af5d75d9f982ffab6093cda648f07ee1dfc30abfc8ef19894ae7cb6f90b3d3ca4b1a4affe3a19a95f08 510-free_ftpfs_file-memleak-fix.patch
+ffef57586e2023c3257bfa1d48c5dd318c17e80867b2c467ee99a538813d459568260daf23caf84a751a7d1c18fd05b54d967a5d8e740adbd1bac1af1effe74c 520-nocache-memleak-fix.patch
+f3478952ef8667ac808d0a1c97c7211da8a091ef27fe2fc87cb2a685060c479af1422e2a8cfaea6d3cd3014758cbb4cc25a3dbec4d9b50da03195cd294efb296 530-curlftpfs__no_verify_hostname.patch
+4448ee5ebb79e404cc0eb37ef39c510015ef9b8901724c396ffee52bc45ba8c2636f6f3e6ec2dc4390b37c5662b54c72a13df32807dabfc523a0f65f484a8540 540-consistent-feature-flag.patch
+5657e2261012b81fda02488a0aa083d88c3d9ea2b435b38a46dc1e04afc34824aa452dd903f1ac956a37c9c2fa19f65c4021d531450abbe47e074dbad5819a63 550-getpass-prototype.patch"