aboutsummaryrefslogtreecommitdiffstats
path: root/testing/darktable
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-25 22:55:07 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-25 22:59:30 +0100
commitb08d250c745e217477bd620f220a92621508d039 (patch)
treeebb8dd85d12f9f839e7767adaf6b6a565f4123d5 /testing/darktable
parent59122f1069e7fcf338b3bafa26551a4a4871ca49 (diff)
downloadaports-b08d250c745e217477bd620f220a92621508d039.tar.bz2
aports-b08d250c745e217477bd620f220a92621508d039.tar.xz
testing/darktable: add ldpath and remove detected deps from depends
All the runtime dependencies are auto-detected by abuild based on dynamic linking of shared libs.
Diffstat (limited to 'testing/darktable')
-rw-r--r--testing/darktable/APKBUILD33
1 files changed, 27 insertions, 6 deletions
diff --git a/testing/darktable/APKBUILD b/testing/darktable/APKBUILD
index 5ecda0b3dd..0c5d8868a5 100644
--- a/testing/darktable/APKBUILD
+++ b/testing/darktable/APKBUILD
@@ -7,17 +7,38 @@ pkgdesc="an open source photography workflow application and raw developer"
url="https://www.darktable.org/"
arch="all !armhf"
license="GPL3"
-depends="libxslt gtk+3.0 libgphoto2 libwebp lensfun librsvg sqlite curl jpeg
- tiff lcms2 json-glib exiv2 lua5.2 pugixml colord colord-gtk openexr"
-makedepends="cmake intltool gtk+3.0-dev libgphoto2-dev libwebp-dev
- lensfun-dev librsvg-dev sqlite-dev curl-dev jpeg-dev tiff-dev
- lcms2-dev json-glib-dev exiv2-dev lua5.2-dev pugixml-dev
- colord-dev colord-gtk-dev openexr-dev"
+depends=""
+makedepends="
+ cmake
+ colord-dev
+ colord-gtk-dev
+ curl-dev
+ exiv2-dev
+ gtk+3.0-dev
+ intltool
+ jpeg-dev
+ json-glib-dev
+ lcms2-dev
+ lensfun-dev
+ libgphoto2-dev
+ librsvg-dev
+ libwebp-dev
+ libxml2-dev
+ libxml2-utils
+ libxslt
+ lua5.2-dev
+ openexr-dev
+ pugixml-dev
+ sqlite-dev
+ tiff-dev"
+ldpath="/usr/lib/$pkgname"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-lang"
source="https://github.com/darktable-org/darktable/releases/download/release-${pkgver/_/}/darktable-${pkgver/_/.}.tar.xz"
builddir="$srcdir/$pkgname-${pkgver/_/~}"
prepare() {
+ default_prepare || return 1
+
cd "$builddir"
mkdir -p build
}