aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dcfldd
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /testing/dcfldd
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'testing/dcfldd')
-rw-r--r--testing/dcfldd/APKBUILD49
-rw-r--r--testing/dcfldd/dcfldd-error.patch15
2 files changed, 0 insertions, 64 deletions
diff --git a/testing/dcfldd/APKBUILD b/testing/dcfldd/APKBUILD
deleted file mode 100644
index facca26841..0000000000
--- a/testing/dcfldd/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Contributor: Jesse Young <jlyo@jlyo.org>
-# Maintainer: Jesse Young <jlyo@jlyo.org>
-
-pkgname=dcfldd
-pkgver=1.3.4.1
-_pkgver="${pkgver%.*}-${pkgver##*.}"
-pkgrel=0
-pkgdesc="DCFL (DoD Computer Forensics Lab) dd replacement with hashing"
-url="http://dcfldd.sourceforge.net/"
-arch="all"
-license="GPL"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${_pkgver}.tar.gz
- dcfldd-error.patch"
-
-_builddir="${srcdir}/${pkgname}-${_pkgver}"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-md5sums="952026c872f11b53ce0ec6681a3eef0a dcfldd-1.3.4-1.tar.gz
-2e2ee971748845947312f5345b96e940 dcfldd-error.patch"
-sha256sums="f5143a184da56fd5ac729d6d8cbcf9f5da8e1cf4604aa9fb97c59553b7e6d5f8 dcfldd-1.3.4-1.tar.gz
-004408bab8296050107e92e5a5fdf14e3b145acb324bfcf697a29ca9f11218d4 dcfldd-error.patch"
-sha512sums="04b53adf62c6b468ff816e2cd94cf360eb5315eb980e2aa7d71afae706ec9c4683430269e82d712608be265710907fdaaa1316e4f734b7481ee9395a37926c7a dcfldd-1.3.4-1.tar.gz
-f0c33fbc5f2d2eb8075d7faa460987d441da04be6831f85743a0ffd5d58796722395efc8c9dd7137a0b8bbc017b9995cf18b3ef37e56e17fdbd842fcaa573c83 dcfldd-error.patch"
diff --git a/testing/dcfldd/dcfldd-error.patch b/testing/dcfldd/dcfldd-error.patch
deleted file mode 100644
index 5bf0e60758..0000000000
--- a/testing/dcfldd/dcfldd-error.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/util.c
-+++ b/util.c
-@@ -135,9 +133,9 @@
- && ioctl (fdesc, MTIOCGET, &s2) == 0
- && MT_SAME_POSITION (s1, s2))
- {
-+ fprintf(stderr, "%s: warning: working around lseek kernel bug for file (%s)\n"
-+ " of mt_type=0x%0lx -- see <sys/mtio.h> for the list of types\n",
-+ program_name, filename, s2.mt_type);
-- error (0, 0, _("warning: working around lseek kernel bug for file (%s)\n\
-- of mt_type=0x%0lx -- see <sys/mtio.h> for the list of types"),
-- filename, s2.mt_type);
- errno = 0;
- new_position = -1;
- }