aboutsummaryrefslogtreecommitdiffstats
path: root/testing/diffstat
diff options
context:
space:
mode:
authorLeszek Cimała <ernierasta@zori.cz>2016-02-24 22:36:33 +0100
committerTimo Teräs <timo.teras@iki.fi>2016-02-25 09:10:36 +0000
commit2423985c743fefa1cd0dc917f183f262af694602 (patch)
tree4a79a987283ec3faf93f25e41bf0b115a4ad12c4 /testing/diffstat
parentffe3339fa3b694fbe3842722728cd0f7ddd00679 (diff)
downloadaports-2423985c743fefa1cd0dc917f183f262af694602.tar.bz2
aports-2423985c743fefa1cd0dc917f183f262af694602.tar.xz
testing/diffstat: new aport
http://invisible-island.net/diffstat diffstat reads the output of diff and displays a histogram of the insertions, deletions, and modifications per-file.
Diffstat (limited to 'testing/diffstat')
-rw-r--r--testing/diffstat/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/diffstat/APKBUILD b/testing/diffstat/APKBUILD
new file mode 100644
index 0000000000..141937b538
--- /dev/null
+++ b/testing/diffstat/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Leszek Cimała <ernierasta@zori.cz>
+# Maintainer:
+pkgname=diffstat
+pkgver=1.60
+pkgrel=0
+pkgdesc="diffstat reads the output of diff and displays a histogram of the insertions, deletions, and modifications per-file."
+url="http://invisible-island.net/diffstat"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="ftp://invisible-island.net/${pkgname}/${pkgname}-${pkgver}.tgz"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="ba889da4c06b547aa2d78fa96800ae6f diffstat-1.60.tgz"
+sha256sums="2032e418b43bae70d548e32da901ebc4ac12972381de1314bebde0b126fb0123 diffstat-1.60.tgz"
+sha512sums="6cbcff7dfe6d51583d59d2c9dfe4cb958202491ca3c4b1096616380564a1842065434d30858c55c3ddcfc76cd07b58dfc4c4cb6cfdcf6346af60998170f51bd2 diffstat-1.60.tgz"