aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dma
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-02-29 04:52:30 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2016-02-29 04:52:36 +0100
commit55f816571536beb24f6d27b90b354028f0b5242c (patch)
treeb4a1e5c6cd977a2c657dfc0f0e16bb75e67fd8e2 /testing/dma
parentaeb6173bde6a304f9e875557bf4c4f17dad35c1e (diff)
downloadaports-55f816571536beb24f6d27b90b354028f0b5242c.tar.bz2
aports-55f816571536beb24f6d27b90b354028f0b5242c.tar.xz
testing/dma: new aport
Diffstat (limited to 'testing/dma')
-rw-r--r--testing/dma/APKBUILD42
-rw-r--r--testing/dma/musl-fixes.patch38
2 files changed, 80 insertions, 0 deletions
diff --git a/testing/dma/APKBUILD b/testing/dma/APKBUILD
new file mode 100644
index 0000000000..f7d1587369
--- /dev/null
+++ b/testing/dma/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=dma
+pkgver=0.11
+pkgrel=0
+pkgdesc="A small Mail Transport Agent from DragonFly BSD"
+url="https://github.com/corecode/dma"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="bison flex libbsd-dev bsd-compat-headers openssl-dev"
+install=""
+options="suid"
+subpackages="$pkgname-doc"
+options="suid"
+source="$pkgname-$pkgver.tar.gz::https://github.com/corecode/$pkgname/archive/v$pkgver.tar.gz
+ musl-fixes.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ make -C "$_builddir" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install || return 1
+
+ # Install additional documentation files.
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples
+ install -m644 README.markdown TODO \
+ "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+ install -m644 *.conf \
+ "$pkgdir"/usr/share/doc/$pkgname/examples/ || return 1
+}
+
+md5sums="4090572921fc33be0977f4010881b501 dma-0.11.tar.gz
+458a0f8aa745843556dccf4a9fdfe251 musl-fixes.patch"
+sha256sums="288bd57f17aba696b6423b1fa0cd0f7d9b7228d32811f1cd7b821d5f020051b8 dma-0.11.tar.gz
+a46013b72a6e9b6b5ed2badbd590c6e27b426c2fac7e8599764de5cab068674d musl-fixes.patch"
+sha512sums="8ccf85a921da12cbf5b9f2c93dd96da91d2acdace979ed4a6b37af94e72441bf654ac65525fc2c1118c1b16136278de4daeafc753dcaf4300a017e317f83fc4d dma-0.11.tar.gz
+7aac2bd424c8196ecc882e5f4a3c51a1f245ca7c4b112804ddf29e49bb7c4925337038700582c8deaaa84fa2010a4c4d477ba0ca7e881a3a4734333edc0c4c35 musl-fixes.patch"
diff --git a/testing/dma/musl-fixes.patch b/testing/dma/musl-fixes.patch
new file mode 100644
index 0000000000..57eb480328
--- /dev/null
+++ b/testing/dma/musl-fixes.patch
@@ -0,0 +1,38 @@
+diff -upr dma-0.11.orig/dfcompat.c dma-0.11/dfcompat.c
+--- dma-0.11.orig/dfcompat.c 2016-02-29 04:26:15.181591094 +0100
++++ dma-0.11/dfcompat.c 2016-02-29 04:29:34.367403004 +0100
+@@ -105,7 +105,7 @@ reallocf(void *ptr, size_t size)
+
+ #ifndef HAVE_GETPROGNAME
+
+-#ifdef __GLIBC__
++#ifdef __linux__
+
+ #include <errno.h>
+
+diff -upr dma-0.11.orig/dma.h dma-0.11/dma.h
+--- dma-0.11.orig/dma.h 2016-02-29 04:26:15.181591094 +0100
++++ dma-0.11/dma.h 2016-02-29 04:26:53.534759844 +0100
+@@ -38,7 +38,7 @@
+ #define DMA_H
+
+ #include <sys/types.h>
+-#include <sys/queue.h>
++#include <bsd/sys/queue.h>
+ #include <sys/socket.h>
+ #include <arpa/nameser.h>
+ #include <arpa/inet.h>
+diff -upr dma-0.11.orig/dns.c dma-0.11/dns.c
+--- dma-0.11.orig/dns.c 2016-02-29 04:26:15.181591094 +0100
++++ dma-0.11/dns.c 2016-02-29 04:34:32.039446395 +0100
+@@ -42,8 +42,10 @@
+ #include <resolv.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <math.h>
+
+ #include "dma.h"
++#define roundup(x, y) ((((x) + ((y) - 1)) / (y)) * (y))
+
+ static int
+ sort_pref(const void *a, const void *b)