aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dma
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-02-29 05:28:31 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2016-02-29 16:00:51 +0100
commitb200676e679fc33c2ef9a231098af8b74250f9a6 (patch)
treeb9f86cbb284476351b175a6467f3599818143f98 /testing/dma
parent8a21bd597edb2fd5484622c92e98915f0ef2698e (diff)
downloadaports-b200676e679fc33c2ef9a231098af8b74250f9a6.tar.bz2
aports-b200676e679fc33c2ef9a231098af8b74250f9a6.tar.xz
testing/dma: Instal configs to /etc and create spool directory
Diffstat (limited to 'testing/dma')
-rw-r--r--testing/dma/APKBUILD18
-rw-r--r--testing/dma/musl-fixes.patch19
2 files changed, 19 insertions, 18 deletions
diff --git a/testing/dma/APKBUILD b/testing/dma/APKBUILD
index f7d1587369..5f2f5142c6 100644
--- a/testing/dma/APKBUILD
+++ b/testing/dma/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=dma
pkgver=0.11
-pkgrel=0
+pkgrel=1
pkgdesc="A small Mail Transport Agent from DragonFly BSD"
url="https://github.com/corecode/dma"
arch="all"
@@ -13,7 +13,6 @@ makedepends="bison flex libbsd-dev bsd-compat-headers openssl-dev"
install=""
options="suid"
subpackages="$pkgname-doc"
-options="suid"
source="$pkgname-$pkgver.tar.gz::https://github.com/corecode/$pkgname/archive/v$pkgver.tar.gz
musl-fixes.patch"
@@ -24,19 +23,22 @@ build() {
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir" PREFIX=/usr install || return 1
+ make DESTDIR="$pkgdir" PREFIX=/usr \
+ install install-etc || return 1
+
+ # Create spool directory.
+ install -d -o root -g mail \
+ -m 775 "$pkgdir"/var/spool/$pkgname || return 1
# Install additional documentation files.
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples
install -m644 README.markdown TODO \
"$pkgdir"/usr/share/doc/$pkgname/ || return 1
- install -m644 *.conf \
- "$pkgdir"/usr/share/doc/$pkgname/examples/ || return 1
}
md5sums="4090572921fc33be0977f4010881b501 dma-0.11.tar.gz
-458a0f8aa745843556dccf4a9fdfe251 musl-fixes.patch"
+dae016c71deec1db57604149f2644537 musl-fixes.patch"
sha256sums="288bd57f17aba696b6423b1fa0cd0f7d9b7228d32811f1cd7b821d5f020051b8 dma-0.11.tar.gz
-a46013b72a6e9b6b5ed2badbd590c6e27b426c2fac7e8599764de5cab068674d musl-fixes.patch"
+e7c39867da5e9c4cd91e0c82e071f770f3e615815c0bb47dd37eb9b2ec2242f0 musl-fixes.patch"
sha512sums="8ccf85a921da12cbf5b9f2c93dd96da91d2acdace979ed4a6b37af94e72441bf654ac65525fc2c1118c1b16136278de4daeafc753dcaf4300a017e317f83fc4d dma-0.11.tar.gz
-7aac2bd424c8196ecc882e5f4a3c51a1f245ca7c4b112804ddf29e49bb7c4925337038700582c8deaaa84fa2010a4c4d477ba0ca7e881a3a4734333edc0c4c35 musl-fixes.patch"
+051af3d10711f7565fedd3a06c152454020e903e2e923a37cc77ccbf4346f308edecfe4f3d3c37a3cb2e54d1fb336bb4d9cea2a7d6dc560aec3c2369eb55e6a9 musl-fixes.patch"
diff --git a/testing/dma/musl-fixes.patch b/testing/dma/musl-fixes.patch
index 57eb480328..bf7d805b2f 100644
--- a/testing/dma/musl-fixes.patch
+++ b/testing/dma/musl-fixes.patch
@@ -1,6 +1,6 @@
diff -upr dma-0.11.orig/dfcompat.c dma-0.11/dfcompat.c
---- dma-0.11.orig/dfcompat.c 2016-02-29 04:26:15.181591094 +0100
-+++ dma-0.11/dfcompat.c 2016-02-29 04:29:34.367403004 +0100
+--- dma-0.11.orig/dfcompat.c 2016-02-29 15:33:18.153280618 +0100
++++ dma-0.11/dfcompat.c 2016-02-29 15:33:25.749914514 +0100
@@ -105,7 +105,7 @@ reallocf(void *ptr, size_t size)
#ifndef HAVE_GETPROGNAME
@@ -11,8 +11,8 @@ diff -upr dma-0.11.orig/dfcompat.c dma-0.11/dfcompat.c
#include <errno.h>
diff -upr dma-0.11.orig/dma.h dma-0.11/dma.h
---- dma-0.11.orig/dma.h 2016-02-29 04:26:15.181591094 +0100
-+++ dma-0.11/dma.h 2016-02-29 04:26:53.534759844 +0100
+--- dma-0.11.orig/dma.h 2016-02-29 15:33:18.153280618 +0100
++++ dma-0.11/dma.h 2016-02-29 15:33:25.749914514 +0100
@@ -38,7 +38,7 @@
#define DMA_H
@@ -23,16 +23,15 @@ diff -upr dma-0.11.orig/dma.h dma-0.11/dma.h
#include <arpa/nameser.h>
#include <arpa/inet.h>
diff -upr dma-0.11.orig/dns.c dma-0.11/dns.c
---- dma-0.11.orig/dns.c 2016-02-29 04:26:15.181591094 +0100
-+++ dma-0.11/dns.c 2016-02-29 04:34:32.039446395 +0100
-@@ -42,8 +42,10 @@
- #include <resolv.h>
- #include <string.h>
+--- dma-0.11.orig/dns.c 2016-02-29 15:33:18.153280618 +0100
++++ dma-0.11/dns.c 2016-02-29 15:33:30.979891954 +0100
+@@ -44,6 +44,9 @@
#include <stdlib.h>
-+#include <math.h>
#include "dma.h"
++#ifndef roundup
+#define roundup(x, y) ((((x) + ((y) - 1)) / (y)) * (y))
++#endif
static int
sort_pref(const void *a, const void *b)