aboutsummaryrefslogtreecommitdiffstats
path: root/testing/eatmemory
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-29 01:52:49 +0000
committerShiz <hi@shiz.me>2017-07-31 02:43:33 +0200
commit6b462e9dd9bd9ec9a1be9e0c696ffb2a977711b9 (patch)
tree5603a1dc0f435f02944c1e1d7e90546e36d73654 /testing/eatmemory
parentb53046180ad75645a4d44547431364fdcf75cc4a (diff)
downloadaports-6b462e9dd9bd9ec9a1be9e0c696ffb2a977711b9.tar.bz2
aports-6b462e9dd9bd9ec9a1be9e0c696ffb2a977711b9.tar.xz
testing/eatmemory: upgrade to 0.1.6 and modernize APKBUILD
Diffstat (limited to 'testing/eatmemory')
-rw-r--r--testing/eatmemory/APKBUILD24
-rw-r--r--testing/eatmemory/makefile.patch5
2 files changed, 8 insertions, 21 deletions
diff --git a/testing/eatmemory/APKBUILD b/testing/eatmemory/APKBUILD
index 4103100f59..c1c96684cf 100644
--- a/testing/eatmemory/APKBUILD
+++ b/testing/eatmemory/APKBUILD
@@ -1,40 +1,26 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=eatmemory
-pkgver=0.1.4
+pkgver=0.1.6
pkgrel=0
pkgdesc="Simple C program to allocate memory from the command line"
url="https://github.com/julman99/eatmemory"
arch="all"
license="Custom"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=
-subpackages=
source="$pkgname-$pkgver.tar.gz::https://github.com/julman99/eatmemory/archive/v$pkgver.tar.gz
makefile.patch
"
builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$builddir"
- default_prepare || return 1
-}
-
build() {
cd "$builddir"
- make || return 1
+ make
}
package() {
cd "$builddir"
- make PREFIX="$pkgdir" install || return 1
+ make PREFIX="$pkgdir" install
}
-md5sums="9e4a35dc12be649ae2da45815b7da8bc eatmemory-0.1.4.tar.gz
-30697f50cf63cae4f1d72e3b574f63f3 makefile.patch"
-sha256sums="c4744e6b57129823b14e89f4bca39583b7ca2391ee8630c5f9b6f7217ad42cc4 eatmemory-0.1.4.tar.gz
-70d23b9ae74df6e408c4b9a7923df034d072dba6c3f0aed2f8bb2898bb524b8c makefile.patch"
-sha512sums="e2c1dfb20c050a4697a92588ad537c7784668b1dad978717a486441117f2e6c1f789ceb3bdff545354b7affceb9ff25d4d291d0499410bec68e89a91a5a4f435 eatmemory-0.1.4.tar.gz
-db1e48e71b1ce9754147c67a6ffeeae4f7e63895a5922b8213ae8ca7174bdefb552fce9c94b25891470e0daf6fd3fa86dfaf3569fa5572a31ceb15eac5b9e59e makefile.patch"
+sha512sums="e2f3b945c7c00ee9aff2ba3f17a7020c2b2632e904faa8bdbe233998e777622e0151d052f9c5f10a0260f6213b0fa10129f11cedbc1f1db42d06a20909487728 eatmemory-0.1.6.tar.gz
+6a7ca49059ae1b952f107a4f4dbf7e9bdffa5ad752c09ce7be0e7049d9bfd6c71c6a07bbfc425a44db24404f5bc01ca16084541167079596ece7886b9ee6bb22 makefile.patch"
diff --git a/testing/eatmemory/makefile.patch b/testing/eatmemory/makefile.patch
index a838373a86..568c5dd638 100644
--- a/testing/eatmemory/makefile.patch
+++ b/testing/eatmemory/makefile.patch
@@ -1,10 +1,11 @@
--- a/Makefile
+++ b/Makefile
-@@ -2,7 +2,7 @@
+@@ -2,8 +2,7 @@
$(CC) eatmemory.c -o eatmemory
install: eatmemory
-- install -m 0755 eatmemory $(PREFIX)/usr/bin/eatmemory
+- mkdir -p $(PREFIX)/bin
+- install -m 0755 eatmemory $(PREFIX)/bin/
+ install -D -m 0755 eatmemory $(PREFIX)/usr/bin/eatmemory
clean: