aboutsummaryrefslogtreecommitdiffstats
path: root/testing/evolution-data-server
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-27 22:08:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-27 22:15:12 +0000
commit7d299efdbc1d537c715d34ba4495feb359963927 (patch)
treefc64353e5a682ed6e8b27f2bed2d2727dbe82ae0 /testing/evolution-data-server
parent949fe77a80dfe8feff60af1e65110f686bbc221f (diff)
downloadaports-7d299efdbc1d537c715d34ba4495feb359963927.tar.bz2
aports-7d299efdbc1d537c715d34ba4495feb359963927.tar.xz
testing/evolution-data-server: upgrade to 2.32.3
needed various fixes for recent glib version
Diffstat (limited to 'testing/evolution-data-server')
-rw-r--r--testing/evolution-data-server/APKBUILD17
-rw-r--r--testing/evolution-data-server/g_atomic_int_exchange_and_add.patch45
-rw-r--r--testing/evolution-data-server/g_unicode_canonical_decomposition.patch57
3 files changed, 113 insertions, 6 deletions
diff --git a/testing/evolution-data-server/APKBUILD b/testing/evolution-data-server/APKBUILD
index e7fffe324d..74db2d670f 100644
--- a/testing/evolution-data-server/APKBUILD
+++ b/testing/evolution-data-server/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=evolution-data-server
-pkgver=2.32.2
-pkgrel=6
+pkgver=2.32.3
+pkgrel=0
pkgdesc="data server for evolution"
url="http://projects.gnome.org/evolution"
arch="all"
@@ -11,8 +11,11 @@ depends=
depends_dev="gtk+-dev glib-dev libsoup-dev libxml2-dev gconf-dev libgdata-dev db-dev libgweather-dev libgnome-keyring-dev libical-dev nspr-dev nss-dev sqlite-dev"
makedepends="$depends_dev gperf flex bison"
install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="ftp://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="ftp://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ g_unicode_canonical_decomposition.patch
+ g_atomic_int_exchange_and_add.patch
+ "
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -33,7 +36,7 @@ build() {
cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
- --disable-scrollkeeper || return 1
+ || return 1
make || return 1
}
@@ -43,4 +46,6 @@ package() {
find "$pkgdir" -name '*.la' -delete
}
-md5sums="19d230667c0dfb1c06b8fe951fd552ff evolution-data-server-2.32.2.tar.bz2"
+md5sums="480bab0702991692f9dee9fecfc49f48 evolution-data-server-2.32.3.tar.bz2
+464467c7a90ca790002356046dae8356 g_unicode_canonical_decomposition.patch
+2578f99935e070bd4db96a08f1bdb819 g_atomic_int_exchange_and_add.patch"
diff --git a/testing/evolution-data-server/g_atomic_int_exchange_and_add.patch b/testing/evolution-data-server/g_atomic_int_exchange_and_add.patch
new file mode 100644
index 0000000000..59c114134b
--- /dev/null
+++ b/testing/evolution-data-server/g_atomic_int_exchange_and_add.patch
@@ -0,0 +1,45 @@
+From 1886d3d0573388aa5c13af99f714687ba6a66ec6 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Wed, 01 Jun 2011 05:22:14 +0000
+Subject: Replace deprecated g_atomic_int_exchange_and_add()
+
+---
+(limited to 'addressbook/libedata-book/e-data-book.c')
+
+diff --git a/addressbook/libedata-book/e-data-book.c b/addressbook/libedata-book/e-data-book.c
+index 9e17703..1a29e4b 100644
+--- a/addressbook/libedata-book/e-data-book.c
++++ b/addressbook/libedata-book/e-data-book.c
+@@ -117,7 +117,7 @@ construct_bookview_path (void)
+
+ return g_strdup_printf ("/org/gnome/evolution/dataserver/AddressBookView/%d/%d",
+ getpid (),
+- g_atomic_int_exchange_and_add ((int*)&counter, 1));
++ g_atomic_int_add ((int*)&counter, 1));
+ }
+
+ static void
+--
+cgit v0.9.0.2
+--- ./addressbook/libedata-book/e-data-book-factory.c.orig
++++ ./addressbook/libedata-book/e-data-book-factory.c
+@@ -229,7 +229,7 @@
+
+ return g_strdup_printf (
+ "/org/gnome/evolution/dataserver/addressbook/%d/%u",
+- getpid (), g_atomic_int_exchange_and_add (&counter, 1));
++ getpid (), g_atomic_int_add (&counter, 1));
+ }
+
+ static gboolean
+--- ./calendar/libedata-cal/e-data-cal-factory.c.orig
++++ ./calendar/libedata-cal/e-data-cal-factory.c
+@@ -245,7 +245,7 @@
+
+ return g_strdup_printf (
+ "/org/gnome/evolution/dataserver/calendar/%d/%u",
+- getpid (), g_atomic_int_exchange_and_add (&counter, 1));
++ getpid (), g_atomic_int_add (&counter, 1));
+ }
+
+ static gboolean
diff --git a/testing/evolution-data-server/g_unicode_canonical_decomposition.patch b/testing/evolution-data-server/g_unicode_canonical_decomposition.patch
new file mode 100644
index 0000000000..d00a06ddce
--- /dev/null
+++ b/testing/evolution-data-server/g_unicode_canonical_decomposition.patch
@@ -0,0 +1,57 @@
+From f1c9292caa3b26c890d628e99677dd05d62eba99 Mon Sep 17 00:00:00 2001
+From: Vincent Untz <vuntz@gnome.org>
+Date: Tue, 06 Sep 2011 14:43:04 +0000
+Subject: Bug #655837 - Avoid use of deprecated g_unicode_canonical_decomposition
+
+---
+(limited to 'libedataserver/e-data-server-util.c')
+
+diff --git a/libedataserver/e-data-server-util.c b/libedataserver/e-data-server-util.c
+index 4c0310a..3f2ff02 100644
+--- a/libedataserver/e-data-server-util.c
++++ b/libedataserver/e-data-server-util.c
+@@ -251,7 +251,12 @@ e_util_utf8_strstrcase (const gchar *haystack,
+ static gunichar
+ stripped_char (gunichar ch)
+ {
+- gunichar *decomp, retval;
++#if GLIB_CHECK_VERSION(2,29,12)
++ gunichar decomp[4];
++#else
++ gunichar *decomp;
++#endif
++ gunichar retval;
+ GUnicodeType utype;
+ gsize dlen;
+
+@@ -268,11 +273,18 @@ stripped_char (gunichar ch)
+ /* Convert to lowercase, fall through */
+ ch = g_unichar_tolower (ch);
+ case G_UNICODE_LOWERCASE_LETTER:
++#if GLIB_CHECK_VERSION(2,29,12)
++ if ((dlen = g_unichar_fully_decompose (ch, FALSE, decomp, 4))) {
++ retval = decomp[0];
++ return retval;
++ }
++#else
+ if ((decomp = g_unicode_canonical_decomposition (ch, &dlen))) {
+ retval = decomp[0];
+ g_free (decomp);
+ return retval;
+ }
++#endif
+ break;
+ }
+
+--
+cgit v0.9.0.2
+--- ./libedataserver/e-data-server-util.c.orig
++++ ./libedataserver/e-data-server-util.c
+@@ -260,7 +260,6 @@
+ case G_UNICODE_CONTROL:
+ case G_UNICODE_FORMAT:
+ case G_UNICODE_UNASSIGNED:
+- case G_UNICODE_COMBINING_MARK:
+ /* Ignore those */
+ return 0;
+ default: