aboutsummaryrefslogtreecommitdiffstats
path: root/testing/exa
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-09 15:42:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-09 18:29:15 -0300
commit8d786b85b1e55c61ea512dd873b176fdf2182521 (patch)
tree4c4e3d22fe3fbb9ef6b13dadf70c178e8c1e5e31 /testing/exa
parentc98202b3f1a6d247d865b035c72942c856cc1bbe (diff)
downloadaports-8d786b85b1e55c61ea512dd873b176fdf2182521.tar.bz2
aports-8d786b85b1e55c61ea512dd873b176fdf2182521.tar.xz
testing/exa: new aport
ls replacement written in Rust https://the.exa.website
Diffstat (limited to 'testing/exa')
-rw-r--r--testing/exa/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/exa/APKBUILD b/testing/exa/APKBUILD
new file mode 100644
index 0000000000..344e7f62c1
--- /dev/null
+++ b/testing/exa/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=exa
+pkgver=0.8.0
+pkgrel=0
+pkgdesc="ls replacement written in Rust"
+url="https://the.exa.website/"
+options="!check" # Tests fail on drone-ci
+arch="x86_64" # Limited by cargo
+license="MIT"
+makedepends="cargo cmake"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ogham/exa/archive/v$pkgver.tar.gz"
+
+build() {
+ cargo build --release
+}
+
+check() {
+ cargo test --release
+}
+
+package() {
+ cargo install --path . --root="$pkgdir"/usr
+ rm "$pkgdir"/usr/.crates.toml
+ install -Dm644 contrib/man/exa.1 "$pkgdir"/usr/share/man/man1/exa.1
+}
+sha512sums="5ac142f40af8408e03e7fa7b204216182ad696e44c1d044bd73d04957a638a8ed7295c15fc49279165b5dfb2d8b6a559847930de0e267f479cdab88fe9c49beb exa-0.8.0.tar.gz"