aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fastd
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-11-09 00:35:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-09 09:57:17 +0000
commit0ac24a76245ef7cf9952b96e49a9d85d8bcb3e93 (patch)
tree179b02f3bf90b994ce43b928fa3c257b16e1dcc0 /testing/fastd
parent97f4f73164cec34e0198c5be81bc5b937ae74bb4 (diff)
downloadaports-0ac24a76245ef7cf9952b96e49a9d85d8bcb3e93.tar.bz2
aports-0ac24a76245ef7cf9952b96e49a9d85d8bcb3e93.tar.xz
testing/fastd: rebuild against libsodium + fix init
Diffstat (limited to 'testing/fastd')
-rw-r--r--testing/fastd/APKBUILD14
-rwxr-xr-xtesting/fastd/fastd.initd2
2 files changed, 8 insertions, 8 deletions
diff --git a/testing/fastd/APKBUILD b/testing/fastd/APKBUILD
index 1df56388b2..1ae17dff09 100644
--- a/testing/fastd/APKBUILD
+++ b/testing/fastd/APKBUILD
@@ -2,15 +2,15 @@
# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
pkgname=fastd
pkgver=17
-pkgrel=0
+pkgrel=1
pkgdesc="Fast and Secure Tunneling Daemon"
url="https://projects.universe-factory.net/projects/fastd"
arch="all"
license="BSD"
depends=""
-depends_dev="bsd-compat-headers linux-headers libsodium-dev libcap-dev
- libuecc-dev json-c-dev"
-makedepends="$depends_dev cmake doxygen bison"
+depends_dev=""
+makedepends="$depends_dev cmake doxygen bison bsd-compat-headers linux-headers
+ libsodium-dev libcap-dev libuecc-dev json-c-dev"
install=""
subpackages="$pkgname-doc"
source="http://git.universe-factory.net/${pkgname}/snapshot/${pkgname}-${pkgver}.tar
@@ -54,10 +54,10 @@ package() {
md5sums="40c9efd2c7eaba42b9b93add4a462b17 fastd-17.tar
383a11cb8d804e6d91c2c66eb07b4246 fastd.conf
-f9516c8219b304ddb3ab5dc205e82937 fastd.initd"
+12acdd1bd9b4181d913823575f4c1a78 fastd.initd"
sha256sums="20390fc2110929ebf37feebe1bcce68d7920a5efd42c369bd2d886c6781966dc fastd-17.tar
6c7821e9c6b85ee2baf2d5e2e7b1eb28d3ceebe876e3cb6686b3c1cb6649db68 fastd.conf
-dfc473baee3b7e1e509131010dc3d0a1b62bc7c684cc54daca1a91255e4a0dd2 fastd.initd"
+1d8ebb8e2d6f5201ca6ebe11c0c3e2e124dfafa6f66ebac03a0b27f920f318dc fastd.initd"
sha512sums="152e9b6a2df39375061aedee2e2ac586916ae634cd57ee8902f152d86a27db5d6353f411e038139721073caf35696c349aed2c09165578d81fe47daebead18e8 fastd-17.tar
3e6c3a77f93a1e670e8f018833c499e8ec57b8240a6f472da03254ad9a7e6fed2c3459fa47b06c97e42afcfe6f0adfaaec39bce6b6a286a1ce7ef3585853b118 fastd.conf
-c0fff880384aa35e9d1d84ce98b2a103f1e974dfa54a29a65d7f0ff7d6e4b88d7afa51f0c1025b68078885d310f3a7a1d941149ec49025675d23310597c55906 fastd.initd"
+e64b0c548cf063624ac0b632bac672c5f204586aa03aa9b06afc46f48645f1458e2400e98ee993c74aa5da3a9e86c4151e2e29c634ee59941cd81a216cea308a fastd.initd"
diff --git a/testing/fastd/fastd.initd b/testing/fastd/fastd.initd
index a97854697a..37f497082f 100755
--- a/testing/fastd/fastd.initd
+++ b/testing/fastd/fastd.initd
@@ -1,4 +1,4 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
VPN=${SVCNAME#*.}
if [ ${SVCNAME} != "fastd" ]; then