aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fdm/fix-base64.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-01-24 14:34:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-01-24 14:36:25 +0000
commit7b4bc6db085a398bb7604cc67c26ff95c566e1ab (patch)
tree96ee5280038b41f8feb2be9066dea302f0c97b03 /testing/fdm/fix-base64.patch
parent5697d26dedf6d8ca69f72654eca3526130515ebc (diff)
downloadaports-7b4bc6db085a398bb7604cc67c26ff95c566e1ab.tar.bz2
aports-7b4bc6db085a398bb7604cc67c26ff95c566e1ab.tar.xz
testing/fdm: new aport
A simple lightweight tool of fetching, filtering and delivering emails https://github.com/nicm/fdm
Diffstat (limited to 'testing/fdm/fix-base64.patch')
-rw-r--r--testing/fdm/fix-base64.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/fdm/fix-base64.patch b/testing/fdm/fix-base64.patch
new file mode 100644
index 0000000000..0326f57c36
--- /dev/null
+++ b/testing/fdm/fix-base64.patch
@@ -0,0 +1,52 @@
+From 519e41833c1f7d353c09d8d51bfd6d13d0cfc16c Mon Sep 17 00:00:00 2001
+From: Nicholas Marriott <nicholas.marriott@gmail.com>
+Date: Mon, 18 Feb 2019 22:26:29 +0000
+Subject: [PATCH] Do not add base64.c twice, from Rosen Penev.
+
+---
+ Makefile.am | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 611ae87..e9f2f64 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -123,6 +123,3 @@ endif
+ if NO_STRTONUM
+ nodist_fdm_SOURCES += compat/strtonum.c
+ endif
+-if NO_B64_NTOP
+-nodist_fdm_SOURCES += compat/base64.c
+-endif
+From 3232e537ccaba4417b25d9d70264e4a5533042da Mon Sep 17 00:00:00 2001
+From: Nicholas Marriott <nicholas.marriott@gmail.com>
+Date: Mon, 18 Mar 2019 13:04:00 +0000
+Subject: [PATCH] Fix bas64 declarations, from makepost at firemail dot cc.
+
+---
+ fdm.h | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/fdm.h b/fdm.h
+index 41eaa37..511a7b1 100644
+--- a/fdm.h
++++ b/fdm.h
+@@ -20,7 +20,6 @@
+ #define FDM_H
+
+ #include <sys/param.h>
+-#include <sys/cdefs.h>
+ #include <sys/stat.h>
+
+ #ifdef HAVE_QUEUE_H
+@@ -725,8 +724,8 @@ size_t strlcat(char *, const char *, size_t);
+
+ #ifndef HAVE_B64_NTOP
+ /* base64.c */
+-int b64_ntop(src, srclength, target, targsize);
+-int b64_pton(src, target, targsize);
++int b64_ntop(u_char const *, size_t, char *, size_t);
++int b64_pton(char const *, u_char *, size_t);
+ #endif
+
+ /* shm.c */