aboutsummaryrefslogtreecommitdiffstats
path: root/testing/filebeat/filebeat.yml
diff options
context:
space:
mode:
authorGennady Feldman <gena01@gmail.com>2017-01-02 21:45:06 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-02-07 10:31:47 +0200
commite67aea1521e6de3d9951f7428e67e074e03e66fc (patch)
treeb9e18bdfc62dfe01a812201498a87eba611ff806 /testing/filebeat/filebeat.yml
parentef1fbe5fbeb1d0ef19091c4d2299a3123ab78765 (diff)
downloadaports-e67aea1521e6de3d9951f7428e67e074e03e66fc.tar.bz2
aports-e67aea1521e6de3d9951f7428e67e074e03e66fc.tar.xz
testing/filebeat: upgrade to 5.1.2 and add service script
* Upgrade to latest 5.1.2 release * Added service script for filebeat * Cleanup/update APKBUILD
Diffstat (limited to 'testing/filebeat/filebeat.yml')
-rw-r--r--testing/filebeat/filebeat.yml119
1 files changed, 119 insertions, 0 deletions
diff --git a/testing/filebeat/filebeat.yml b/testing/filebeat/filebeat.yml
new file mode 100644
index 0000000000..6533f9d359
--- /dev/null
+++ b/testing/filebeat/filebeat.yml
@@ -0,0 +1,119 @@
+###################### Filebeat Configuration Example #########################
+
+# This file is an example configuration file highlighting only the most common
+# options. The filebeat.full.yml file from the same directory contains all the
+# supported options with more comments. You can use it as a reference.
+#
+# You can find the full configuration reference here:
+# https://www.elastic.co/guide/en/beats/filebeat/index.html
+
+
+path.config: /etc/filebeat
+path.data: /var/lib/filebeat
+path.logs: /var/log/filebeat
+
+#=========================== Filebeat prospectors =============================
+
+filebeat.prospectors:
+
+# Each - is a prospector. Most options can be set at the prospector level, so
+# you can use different prospectors for various configurations.
+# Below are the prospector specific configurations.
+
+- input_type: log
+
+ # Paths that should be crawled and fetched. Glob based paths.
+ paths:
+ - /var/log/*.log
+ #- c:\programdata\elasticsearch\logs\*
+
+ # Exclude lines. A list of regular expressions to match. It drops the lines that are
+ # matching any regular expression from the list.
+ #exclude_lines: ["^DBG"]
+
+ # Include lines. A list of regular expressions to match. It exports the lines that are
+ # matching any regular expression from the list.
+ #include_lines: ["^ERR", "^WARN"]
+
+ # Exclude files. A list of regular expressions to match. Filebeat drops the files that
+ # are matching any regular expression from the list. By default, no files are dropped.
+ #exclude_files: [".gz$"]
+
+ # Optional additional fields. These field can be freely picked
+ # to add additional information to the crawled log files for filtering
+ #fields:
+ # level: debug
+ # review: 1
+
+ ### Multiline options
+
+ # Mutiline can be used for log messages spanning multiple lines. This is common
+ # for Java Stack Traces or C-Line Continuation
+
+ # The regexp Pattern that has to be matched. The example pattern matches all lines starting with [
+ #multiline.pattern: ^\[
+
+ # Defines if the pattern set under pattern should be negated or not. Default is false.
+ #multiline.negate: false
+
+ # Match can be set to "after" or "before". It is used to define if lines should be append to a pattern
+ # that was (not) matched before or after or as long as a pattern is not matched based on negate.
+ # Note: After is the equivalent to previous and before is the equivalent to to next in Logstash
+ #multiline.match: after
+
+
+#================================ General =====================================
+
+# The name of the shipper that publishes the network data. It can be used to group
+# all the transactions sent by a single shipper in the web interface.
+#name:
+
+# The tags of the shipper are included in their own field with each
+# transaction published.
+#tags: ["service-X", "web-tier"]
+
+# Optional fields that you can specify to add additional information to the
+# output.
+#fields:
+# env: staging
+
+#================================ Outputs =====================================
+
+# Configure what outputs to use when sending the data collected by the beat.
+# Multiple outputs may be used.
+
+#-------------------------- Elasticsearch output ------------------------------
+output.elasticsearch:
+ # Array of hosts to connect to.
+ hosts: ["localhost:9200"]
+
+ # Optional protocol and basic auth credentials.
+ #protocol: "https"
+ #username: "elastic"
+ #password: "changeme"
+
+#----------------------------- Logstash output --------------------------------
+#output.logstash:
+ # The Logstash hosts
+ #hosts: ["localhost:5044"]
+
+ # Optional SSL. By default is off.
+ # List of root certificates for HTTPS server verifications
+ #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]
+
+ # Certificate for SSL client authentication
+ #ssl.certificate: "/etc/pki/client/cert.pem"
+
+ # Client Certificate Key
+ #ssl.key: "/etc/pki/client/cert.key"
+
+#================================ Logging =====================================
+
+# Sets log level. The default log level is info.
+# Available log levels are: critical, error, warning, info, debug
+#logging.level: debug
+
+# At debug level, you can selectively enable logging only for some components.
+# To enable all selectors use ["*"]. Examples of other selectors are "beat",
+# "publish", "service".
+#logging.selectors: ["*"]