aboutsummaryrefslogtreecommitdiffstats
path: root/testing/firefox
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-03-11 14:19:04 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-03-11 14:47:05 +0000
commit44c9895cde49981633d8351f83822d57131cc534 (patch)
tree7201a6c90b8b81b14e8fd88c22cc02b545cdbbcd /testing/firefox
parent309637ea3d1d4d9ea735ad88dfc5eeb0b40e0630 (diff)
downloadaports-44c9895cde49981633d8351f83822d57131cc534.tar.bz2
aports-44c9895cde49981633d8351f83822d57131cc534.tar.xz
testing/firefox: fix x86 build
Diffstat (limited to 'testing/firefox')
-rw-r--r--testing/firefox/APKBUILD4
-rw-r--r--testing/firefox/disable-moz-stackwalk.patch17
2 files changed, 21 insertions, 0 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index a81bb756dc..708823259e 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -61,6 +61,7 @@ source="https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkg
fix-tools.patch
fix-seccomp-bpf.patch
mozilla-build-arm.patch
+ disable-moz-stackwalk.patch
stab.h
rhbz-966424.patch
@@ -177,6 +178,7 @@ b18bd948aae828e5c8f5f63e440c96d6 fix-arm-atomics-grsec.patch
fe88db05a9a1adfd79babd137b0e8de8 fix-tools.patch
aed3b88014fbfbe73db79851e52ca7fa fix-seccomp-bpf.patch
308ba5b54116a035fe68d0d5c3974857 mozilla-build-arm.patch
+4c7a5a634e53c05d8cc67cbd40a3174e disable-moz-stackwalk.patch
4383d038b8d8411ea46f4a109197c19e stab.h
15ebeeeb6823c185f4fed98e9bf1b786 rhbz-966424.patch
f29e0036edc7b3a4158a82fa97bde500 fix-fortify-inline.patch
@@ -195,6 +197,7 @@ ff7cb3c9c4712e0517a6f11e3bf08e9b0d13dbe6384930bdc7f55b1ceed039b5 fix-arm-atomic
b7d43391006443da851c03546f2772ded7770a0ea045e8130be7011cf6718708 fix-tools.patch
517d95225b3323c373c11da6ab867deb76ffdb0b50c1762bdd893abd9b39d4c9 fix-seccomp-bpf.patch
6f5f5e4d2a17182b72b248e896450235ccdaf63252fdb89a8deb55da8adc9be3 mozilla-build-arm.patch
+d87bbd011ec499f93119223360cd79afc628e5f0d020c4e8f0039627c85017e7 disable-moz-stackwalk.patch
960d82bbfdc88c95f5cb4f2e1c1bf23dae7519b3b7203914d7b3ddbff1ba4c28 stab.h
a50d15a640f230a2c66e1eb2afd2bed4117605d0f1591dcfec1ca30f0bc2352f rhbz-966424.patch
ecf808ef1bc2920f6f7a4786fafb46c74e8a2c3bc628f28f10d6e8e1a265e609 fix-fortify-inline.patch
@@ -213,6 +216,7 @@ d3f2ec8684aa485e1d08df325281629adb120f2e79c0065b96e14b99ca2968a3c701d18dda1fd1ca
6322912a8b496332c593ee5c2069d346552299781148d6c829321a10be7f6550a6f7aab3d0cfeb08e1c4ecca2a79272ea7a6f31f1d2eb430c1b0041e3699c06c fix-tools.patch
70863b985427b9653ce5e28d6064f078fb6d4ccf43dd1b68e72f97f44868fc0ce063161c39a4e77a0a1a207b7365d5dc7a7ca5e68c726825eba814f2b93e2f5d fix-seccomp-bpf.patch
e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb18b9e3138273ea8ddcfdcb1084fdcaa922a1e5b30146a3b18 mozilla-build-arm.patch
+c69cdb2d6c66180d6a67c386b862a5ed953aab4db434b054c9e1e6702bcc56ba219a4cb22747d9c891040a286388168e0cf5ca28a503389cd9708012fddf6c2b disable-moz-stackwalk.patch
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
06ededcd196af98b77991dcba3b710b0dfc061404adb4676fcc380be80410a2621f64d67257b0aefdf36f566e0ea1294b5405b7b4db43e83281a1c64d02da579 rhbz-966424.patch
09bc32cf9ee81b9cc6bb58ddbc66e6cc5c344badff8de3435cde5848e5a451e0172153231db85c2385ff05b5d9c20760cb18e4138dfc99060a9e960de2befbd5 fix-fortify-inline.patch
diff --git a/testing/firefox/disable-moz-stackwalk.patch b/testing/firefox/disable-moz-stackwalk.patch
new file mode 100644
index 0000000000..f4e14038b4
--- /dev/null
+++ b/testing/firefox/disable-moz-stackwalk.patch
@@ -0,0 +1,17 @@
+MOZ_STACKWALK_SUPPORTS_LINUX requires GLIBC extensions, Android or
+libunwind. Disable it unconditionally now as otherwise x86 build fails.
+
+--- firefox-45.0/mozglue/misc/StackWalk.cpp.orig
++++ firefox-45.0/mozglue/misc/StackWalk.cpp
+@@ -42,10 +42,7 @@
+ (defined(XP_DARWIN) && \
+ (defined(__i386) || defined(__ppc__) || defined(HAVE__UNWIND_BACKTRACE)))
+
+-#define MOZ_STACKWALK_SUPPORTS_LINUX \
+- (defined(linux) && \
+- ((defined(__GNUC__) && (defined(__i386) || defined(PPC))) || \
+- defined(HAVE__UNWIND_BACKTRACE)))
++#define MOZ_STACKWALK_SUPPORTS_LINUX 0
+
+ #if __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1)
+ #define HAVE___LIBC_STACK_END 1