aboutsummaryrefslogtreecommitdiffstats
path: root/testing/firefox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-01-28 14:37:53 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2016-01-28 14:41:35 +0100
commit72b375d74881fdd9c9f3bba5b9b52aca00df74ef (patch)
tree706f2bdfb02b2c04103b83fccadefd4fe834f68f /testing/firefox
parent6e1d3cf345ed6b20a9481d39ac82fbea7ce723c9 (diff)
downloadaports-72b375d74881fdd9c9f3bba5b9b52aca00df74ef.tar.bz2
aports-72b375d74881fdd9c9f3bba5b9b52aca00df74ef.tar.xz
testing/firefox: work around crash in brotli
brotli will depend on undefined behavior in memcpy() when built without BROTLI_BUILD_PORTABLE. We work around it by explicitly setting it. fortify-headers caught it for us. https://bugzilla.mozilla.org/show_bug.cgi?id=1243724
Diffstat (limited to 'testing/firefox')
-rw-r--r--testing/firefox/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index a92016d6d4..58fbba51d4 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=44.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="Firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -99,7 +99,7 @@ build() {
cd "$_builddir"
# mozilla's buildsystem is on drugs
- export CFLAGS="$(echo $CFLAGS | sed -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')"
+ export CFLAGS="$(echo $CFLAGS | sed -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g') -DBROTLI_BUILD_PORTABLE"
export CXXFLAGS="$CFLAGS"
# set rpath so linker finds the libs