aboutsummaryrefslogtreecommitdiffstats
path: root/testing/firefox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-03 14:50:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-03 14:51:25 +0000
commitf9bff2bb580bf07a0e76266ad47bbac6a48fbbf7 (patch)
tree68cd677c990a0e3d281b28cb6ec4236c80a63fe4 /testing/firefox
parent67f0d66bcc7f22d53d3b00a97fc0c98eaf411430 (diff)
downloadaports-f9bff2bb580bf07a0e76266ad47bbac6a48fbbf7.tar.bz2
aports-f9bff2bb580bf07a0e76266ad47bbac6a48fbbf7.tar.xz
testing/firefox: add firefox-32.0
Diffstat (limited to 'testing/firefox')
-rw-r--r--testing/firefox/APKBUILD162
-rw-r--r--testing/firefox/duckduckgo.patch36
-rw-r--r--testing/firefox/firefox-safe.desktop11
-rw-r--r--testing/firefox/firefox.desktop81
-rw-r--r--testing/firefox/mozconfig51
-rw-r--r--testing/firefox/vendor.js3
6 files changed, 344 insertions, 0 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
new file mode 100644
index 0000000000..356f1c770b
--- /dev/null
+++ b/testing/firefox/APKBUILD
@@ -0,0 +1,162 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=firefox
+pkgver=32.0
+_pkgver=$pkgver
+_xulver=$pkgver
+pkgrel=0
+pkgdesc="firefox web browser"
+url="http://www.firefox.com"
+arch="all"
+license="GPL LGPL MPL"
+depends="xulrunner>=${_xulver}"
+makedepends="xulrunner-dev>=${_xulver}
+
+ nspr-dev
+ nss-dev
+ gtk+-dev
+ mesa-dev
+ icu-dev
+ dbus-glib-dev
+ alsa-lib-dev
+ libvorbis-dev
+ libogg-dev
+ libtheora-dev
+ wireless-tools-dev
+ libnotify-dev
+ libevent-dev
+ libvpx-dev
+ libxt-dev
+ libjpeg-turbo-dev
+ bzip2-dev
+ hunspell-dev
+ startup-notification-dev
+ sqlite-dev
+ libidl-dev
+ gstreamer1-dev
+ gst-plugins-base1-dev
+
+ autoconf2.13
+
+ sed
+ python
+ zip
+ yasm
+
+ autoconf
+ automake
+ libtool
+
+ paxctl"
+install=""
+subpackages="$pkgname-pdfjs $pkgname-dbg"
+source="ftp://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2
+ mozconfig
+ duckduckgo.patch
+ vendor.js
+ firefox.desktop
+ firefox-safe.desktop"
+
+_builddir="${srcdir}/mozilla-release"
+_mozappdir=/usr/lib/firefox-$pkgver
+
+prepare() {
+ local i
+
+ cd "$_builddir"
+
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ cp "${srcdir}/mozconfig" .mozconfig
+ sed -e "s/#${CLIBC}#//g" -i .mozconfig
+
+ echo "ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)" >> .mozconfig
+ if [ -n "$DEBUG" ]; then
+ echo "ac_add_options --enable-debug-symbols" >> .mozconfig
+ echo "ac_add_options --disable-install-strip" >>.mozconfig
+ fi
+}
+
+build() {
+ cd "$_builddir"
+
+ # mozilla's buildsystem is on drugs
+ export CFLAGS="$(echo $CFLAGS | sed -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')"
+ export CXXFLAGS="$CFLAGS"
+
+# export LDFLAGS="-Wl,-rpath,${_mozappdir}"
+ make -j1 -f client.mk build \
+ STRIP="/bin/true" \
+ MOZ_MAKE_FLAGS="$MAKEOPTS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 -f client.mk install \
+ DESTDIR="$pkgdir" \
+ MOZ_MAKE_FLAGS="$MAKEOPTS" \
+ || return 1
+
+ install -m755 -d ${pkgdir}/usr/share/applications
+ install -m755 -d ${pkgdir}/usr/share/pixmaps
+ install -m644 "$_builddir"/browser/branding/official/default48.png \
+ ${pkgdir}/usr/share/pixmaps/firefox.png || return 1
+ install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/firefox.desktop
+ install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/firefox-safe.desktop
+
+ # firefox currently does not work with mprotect. disable it for now
+ local paxflags="-mp"
+ [ "$CARCH" = "x86" ] && paxflags="-msp"
+
+ paxctl -c $paxflags "$pkgdir"/$_mozappdir/firefox || return 1
+
+ # xulrunner stub launcher has changed to using a symlink overlay...
+ # go figure
+ ln -sf /usr/lib/xulrunner-${_xulver} ${pkgdir}/$_mozappdir/xulrunner
+
+ # launcher as symlink is broken from firefox-7.0
+ rm "$pkgdir"/usr/bin/firefox || return 1
+ libgl=$(scanelf -qF '#F%S' /usr/lib/libGL.so)
+ cat > "$pkgdir"/usr/bin/firefox << __EOF__
+#!/bin/sh
+
+# as a workaround for libGL's initial-exec TLS we preload libgl
+# https://bugs.freedesktop.org/show_bug.cgi?id=35268
+
+LD_PRELOAD=$libgl exec $_mozappdir/firefox "\$@"
+__EOF__
+ chmod 755 "$pkgdir"/usr/bin/firefox
+
+ # install our vendor prefs
+ cat "$srcdir"/vendor.js >> "$pkgdir"/$_mozappdir/browser/defaults/preferences/firefox-branding.js
+}
+
+pdfjs() {
+ pkgdesc="Firefox PDF Reader in JavaScript"
+ mkdir -p "$subpkgdir"/$_mozappdir/browser/chrome
+ mv "$pkgdir"/$_mozappdir/browser/chrome/pdfjs \
+ "$subpkgdir"/$_mozappdir/browser/chrome/
+}
+
+md5sums="859d0b6fe2d36b6959cf08cee4c783cc firefox-32.0.source.tar.bz2
+11e6b4bb7593d79fe8827952a3e73c74 mozconfig
+6b8d481d8fba55fa0ad4f26c02164da8 duckduckgo.patch
+1515663477ce427cbdc42f04d8d5ca4e vendor.js
+ba96924ece1d77453e462429037a2ce5 firefox.desktop
+6f38a5899034b7786cb1f75ad42032b8 firefox-safe.desktop"
+sha256sums="3265971e15809ab904403b474fa9eccf15f34697deb16fc400c5c3684afd50eb firefox-32.0.source.tar.bz2
+dca72a9f140bbc37ec7a9bd81ee886f6730b5866fce4e6ca1ebd48ee4df52c42 mozconfig
+db057fd5448c3e4d40459fb8ee178296cc723e19efadb1e02a85a4e22a6e560a duckduckgo.patch
+d72ca759792cc8c88efc664d30087a139fed7fc3d7d058e4cd9ab287bb80ea46 vendor.js
+b571c4a49884a3c98806246c9cc3e60c73d5a8f4aeb7f96217db0be1d6210eda firefox.desktop
+4b6de45753856a890f4482055666e77f9b01bdfb7e0df08bafaa3a4d9937eed3 firefox-safe.desktop"
+sha512sums="e9422c92846bda9dfa4da914be1206c41a8edde7e8bb13d81211433fc2c9013bbaee9bded40f7acf031d675272b04d7902d5631d2932daa3a8a594f768c87974 firefox-32.0.source.tar.bz2
+869b7eb925ccc055ecc3b6fddfa4419b5d2b650d627e551564f76788ed157e1c0a6a42e52e92f65d330957d4839954590ca6f6cf6f26a54a8490bdef18047180 mozconfig
+a7d6a0420f70374a2fa6a74a18ab15c77451f45dc9226ec251f5635a970dbd45ed6cf571ae5ab81b8126951667fc61b1fc5dfb7b8a4d7cc6d465d39e842dc985 duckduckgo.patch
+93570f821e59af4d233fc4b1df85e1d145a5e041ad402fd72921987a5a2f5218538d7a13d59bbf0bda5e7df1d5281407674a3765625936340106d1185b15b5d8 vendor.js
+f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
+5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop"
diff --git a/testing/firefox/duckduckgo.patch b/testing/firefox/duckduckgo.patch
new file mode 100644
index 0000000000..8de4e4b270
--- /dev/null
+++ b/testing/firefox/duckduckgo.patch
@@ -0,0 +1,36 @@
+diff -up mozilla-release/browser/locales/en-US/chrome/browser-region/region.properties.duckduckgo mozilla-release/browser/locales/en-US/chrome/browser-region/region.properties
+--- mozilla-release/browser/locales/en-US/chrome/browser-region/region.properties.duckduckgo 2012-10-24 16:32:26.000000000 +0200
++++ mozilla-release/browser/locales/en-US/chrome/browser-region/region.properties 2012-11-07 16:27:04.278857840 +0100
+@@ -9,6 +9,7 @@ browser.search.defaultenginename=Google
+ browser.search.order.1=Google
+ browser.search.order.2=Yahoo
+ browser.search.order.3=Bing
++browser.search.order.4=DuckDuckGo
+
+ # This is the default set of web based feed handlers shown in the reader
+ # selection UI
+diff -up mozilla-release/browser/locales/en-US/searchplugins/duckduckgo.xml.duckduckgo mozilla-release/browser/locales/en-US/searchplugins/duckduckgo.xml
+--- mozilla-release/browser/locales/en-US/searchplugins/duckduckgo.xml.duckduckgo 2012-11-07 16:27:04.278857840 +0100
++++ mozilla-release/browser/locales/en-US/searchplugins/duckduckgo.xml 2012-11-07 16:27:04.278857840 +0100
+@@ -0,0 +1,11 @@
++<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/">
++ <ShortName>DuckDuckGo</ShortName>
++ <Description>We believe you can get better search and privacy at the same time.</Description>
++ <InputEncoding>UTF-8</InputEncoding>
++ <Image height="16" width="16" type="image/x-icon">data:image/x-icon;base64,AAABAAEAEBAAAAEAIABoBAAAFgAAACgAAAAQAAAAIAAAAAEAIAAAAAAAAAAAANcNAADXDQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAJyDsJmlk8pf6+v3s/v7+++zr/fcnIOyzJyDsgCcg7CYAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAnIOwBJyDscCcg7PZttJ7/7Pfs//////++xO7/S5GA/ycg7P8nIOz2JyDscCcg7AEAAAAAAAAAAAAAAAAnIOwBJyDstScg7P8nIOz/Y8p5/2fHZf9Yv0z/YcF2/1rBUv8nIOz/JyDs/ycg7P8nIOy1JyDsAQAAAAAAAAAAJyDscCcg7P8nIOz/JyDs/4jQoP/p9+n//////05X3v9LkYD/JyDs/ycg7P8nIOz/JyDs/ycg7HAAAAAAJyDsJicg7PYnIOz/JyDs/zUu7f/+/v////////////89N+7/JyDs/yUo7f8nIOz/JyDs/ycg7P8nIOz2JyDsJicg7IAnIOz/JyDs/ycg7P9hXPH////////////t/P//GIr2/wfD+/8Gyfz/DKv5/yM57/8nIOz/JyDs/ycg7H8nIOyzJyDs/ycg7P8nIOz/jov1////////////Otz9/w3G/P8cWfH/JSvt/ycg7P8nIOz/JyDs/ycg7P8nIOyzJyDs5icg7P8nIOz/JyDs/7u5+f///////////27l/v8E0v3/BNL9/wTQ/f8Oofn/IT7v/ycg7P8nIOz/JyDs5icg7OYnIOz/JyDs/ycg7P/p6P3/uWsC////////////5fr//6Po/f8Thfb/DKv5/w6f+f8nIOz/JyDs/ycg7OYnIOyzJyDs/ycg7P8nIOz/9/b+/////////////////7lrAv/V1Pv/JyDs/ycg7P8nIOz/JyDs/ycg7P8nIOyzJyDsgCcg7P8nIOz/JyDs/8/N+///////////////////////iIX1/ycg7P8nIOz/JyDs/ycg7P8nIOz/JyDsfycg7CYnIOz2JyDs/ycg7P9FP+7/q6n4/+7u/f/n5v3/fXn0/yoj7P8nIOz/JyDs/ycg7P8nIOz/JyDs9icg7CYAAAAAJyDscCcg7P8nIOz/wsD6/+no/f/Y1/z/eHTz/ycg7P8nIOz/JyDs/ycg7P8nIOz/JyDs/ycg7HAAAAAAAAAAACcg7AEnIOy1JyDs/ycg7P8nIOz/JyDs/ycg7P8nIOz/JyDs/ycg7P8nIOz/JyDs/ycg7LUnIOwBAAAAAAAAAAAAAAAAJyDsAScg7HAnIOz2JyDs/ycg7P8nIOz/JyDs/ycg7P8nIOz/JyDs9icg7HAnIOwBAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAJyDsJicg7IAnIOyzJyDs5icg7OYnIOyzJyDsgCcg7CYAAAAAAAAAAAAAAAAAAAAA+B8AAPAPAADAAwAAwAMAAIABAAAAAQAAAAAAAAAAAAAAAAAAAAAAAAABAACAAQAAwAMAAMADAADwDwAA+B8AAA==</Image>
++ <Url type="text/html" method="GET" template="https://duckduckgo.com/">
++ <Param name="q" value="{searchTerms}"/>
++ <Param name="t" value="alpine"/>
++ </Url>
++ <SearchForm>https://duckduckgo.com/</SearchForm>
++</SearchPlugin>
+diff -up mozilla-release/browser/locales/en-US/searchplugins/list.txt.duckduckgo mozilla-release/browser/locales/en-US/searchplugins/list.txt
+--- mozilla-release/browser/locales/en-US/searchplugins/list.txt.duckduckgo 2012-10-24 16:32:26.000000000 +0200
++++ mozilla-release/browser/locales/en-US/searchplugins/list.txt 2012-11-07 16:27:04.279857842 +0100
+@@ -1,5 +1,6 @@
+ amazondotcom
+ bing
++duckduckgo
+ eBay
+ google
+ twitter
diff --git a/testing/firefox/firefox-safe.desktop b/testing/firefox/firefox-safe.desktop
new file mode 100644
index 0000000000..1538fc6748
--- /dev/null
+++ b/testing/firefox/firefox-safe.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Exec=firefox -safe-mode %u
+Icon=firefox
+Type=Application
+Terminal=false
+MultipleArgs=false
+Name=Firefox - Safe Mode
+GenericName=Web Browser - Safe Mode
+StartupNotify=false
+Categories=Network;WebBrowser;
diff --git a/testing/firefox/firefox.desktop b/testing/firefox/firefox.desktop
new file mode 100644
index 0000000000..d048ce46c3
--- /dev/null
+++ b/testing/firefox/firefox.desktop
@@ -0,0 +1,81 @@
+[Desktop Entry]
+Exec=firefox %u
+Icon=firefox
+Type=Application
+Terminal=false
+Name=Firefox
+Name[bn]=ফায়ারফক্স3
+Name[eo]=Fajrovulpo3
+Name[fi]=Firefox3
+Name[pa]=ਫਾਇਰਫੋਕਸ3
+Name[tg]=Рӯбоҳи оташин3
+GenericName=Web Browser
+GenericName[af]=Web Blaaier
+GenericName[ar]=متصفح ويب
+GenericName[az]=Veb Səyyahı
+GenericName[bg]=Браузър
+GenericName[bn]=ওয়েব ব্রাউজার
+GenericName[br]=Furcher ar Gwiad
+GenericName[bs]=WWW Preglednik
+GenericName[ca]=Fullejador web
+GenericName[cs]=WWW prohlížeč
+GenericName[cy]=Porydd Gwe
+GenericName[da]=Browser
+GenericName[de]=Web-Browser
+GenericName[el]=Περιηγητής Ιστού
+GenericName[eo]=TTT-legilo
+GenericName[es]=Navegador web
+GenericName[et]=Veebilehitseja
+GenericName[eu]=Web arakatzailea
+GenericName[fa]=مرورگر وب
+GenericName[fi]=WWW-selain
+GenericName[fo]=Alnótsfar
+GenericName[fr]=Navigateur web
+GenericName[gl]=Navegador Web
+GenericName[he]=דפדפן אינטרנט
+GenericName[hi]=वेब ब्राउज़र
+GenericName[hr]=Web preglednik
+GenericName[hu]=Webböngésző
+GenericName[is]=Vafri
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブブラウザ
+GenericName[ko]=웹 브라우저
+GenericName[lo]=ເວັບບຣາວເຊີ
+GenericName[lt]=Žiniatinklio naršyklė
+GenericName[lv]=Web Pārlūks
+GenericName[mk]=Прелистувач на Интернет
+GenericName[mn]=Веб-Хөтөч
+GenericName[nb]=Nettleser
+GenericName[nds]=Nettkieker
+GenericName[nl]=Webbrowser
+GenericName[nn]=Nettlesar
+GenericName[nso]=Seinyakisi sa Web
+GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador Web
+GenericName[ro]=Navigator de web
+GenericName[ru]=Веб-браузер
+GenericName[se]=Fierpmádatlogan
+GenericName[sk]=Webový prehliadač
+GenericName[sl]=Spletni brskalnik
+GenericName[sr]=Веб претраживач
+GenericName[sr@Latn]=Veb pretraživač
+GenericName[ss]=Ibrawuza yeWeb
+GenericName[sv]=Webbläsare
+GenericName[ta]=வலை உலாவி
+GenericName[tg]=Тафсиргари вэб
+GenericName[th]=เว็บบราวเซอร์
+GenericName[tr]=Web Tarayıcı
+GenericName[uk]=Навігатор Тенет
+GenericName[uz]=Веб-браузер
+GenericName[ven]=Buronza ya Webu
+GenericName[vi]=Trình duyệt Web
+GenericName[wa]=Betchteu waibe
+GenericName[xh]=Umkhangeli zincwadi we Web
+GenericName[zh_CN]=网页浏览器
+GenericName[zh_TW]=網頁瀏覽器
+GenericName[zu]=Umcingi we-Web
+MimeType=text/html;
+StartupNotify=true
+Categories=Network;WebBrowser;
diff --git a/testing/firefox/mozconfig b/testing/firefox/mozconfig
new file mode 100644
index 0000000000..1bc3311193
--- /dev/null
+++ b/testing/firefox/mozconfig
@@ -0,0 +1,51 @@
+. $topsrcdir/browser/config/mozconfig
+
+ac_add_options --prefix=/usr
+ac_add_options --libdir=/usr/lib
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-system-png
+ac_add_options --with-system-libvpx
+ac_add_options --with-pthreads
+ac_add_options --disable-tests
+ac_add_options --disable-debug
+ac_add_options --enable-optimize
+ac_add_options --disable-installer
+ac_add_options --enable-xinerama
+ac_add_options --enable-default-toolkit=cairo-gtk2
+ac_add_options --disable-xprint
+ac_add_options --disable-strip
+ac_add_options --enable-pango
+ac_add_options --enable-svg
+ac_add_options --enable-canvas
+ac_add_options --enable-startup-notification
+ac_add_options --enable-libxul
+ac_add_options --with-system-libxul
+ac_add_options --disable-crashreporter
+ac_add_options --disable-updater
+ac_add_options --enable-safe-browsing
+ac_add_options --enable-chrome-format=jar
+ac_add_options --disable-elf-hack
+ac_add_options --enable-libnotify
+ac_add_options --disable-cpp-exceptions
+ac_add_options --enable-url-classifier
+ac_add_options --enable-gio
+ac_add_options --enable-gstreamer=1.0
+ac_add_options --disable-gnomevfs
+ac_add_options --disable-static
+ac_add_options --enable-official-branding
+ac_add_options --with-system-icu
+ac_add_options --disable-pulseaudio
+#uclibc#ac_add_options --enable-jemalloc
+#uclibc#ac_add_options --enable-replace-malloc
+#musl#ac_add_options --disable-jemalloc
+
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export USE_SHORT_LIBNAME=1
+
+mk_add_options BUILD_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
+mk_add_options USE_SHORT_LIBNAME=1
diff --git a/testing/firefox/vendor.js b/testing/firefox/vendor.js
new file mode 100644
index 0000000000..2ef8b0d5b2
--- /dev/null
+++ b/testing/firefox/vendor.js
@@ -0,0 +1,3 @@
+// Disable default browser checking.
+pref("browser.shell.checkDefaultBrowser", false);
+