aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fzy
diff options
context:
space:
mode:
authorEivind Uggedal <eu@eju.no>2019-05-10 14:39:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-05 20:28:49 +0000
commit6a84db1b0e66084466922377e7d28aefda530771 (patch)
treed7e838f64c940945e9688e16b904d435cd7c6749 /testing/fzy
parent34946f61eaeb76cbd71bc5f44e83998290612807 (diff)
downloadaports-6a84db1b0e66084466922377e7d28aefda530771.tar.bz2
aports-6a84db1b0e66084466922377e7d28aefda530771.tar.xz
testing/fzy: enable acceptance tests, adopt package
I've been using fzy from testing for a month without issues. I intend to open a new PR when the new checkdependency hits testing to get this and ruby-ttytest into community.
Diffstat (limited to 'testing/fzy')
-rw-r--r--testing/fzy/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/testing/fzy/APKBUILD b/testing/fzy/APKBUILD
index e094c611be..e43601c849 100644
--- a/testing/fzy/APKBUILD
+++ b/testing/fzy/APKBUILD
@@ -1,32 +1,29 @@
# Contributor: Jonathan Neuschäfer <j.neuschaefer@gmx.net>
+# Maintainer: Eivind Uggedal <eu@eju.no>
pkgname=fzy
pkgver=1.0
-pkgrel=0
+pkgrel=1
pkgdesc="A better fuzzy finder"
url="https://github.com/jhawthorn/$pkgname"
arch="all"
license="MIT"
-depends=""
-makedepends=""
-install=""
+checkdepends="ruby-minitest ruby-ttytest"
subpackages="$pkgname-doc"
source="https://github.com/jhawthorn/fzy/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
make PREFIX="/usr"
}
check() {
- cd "$builddir"
make check
- # In addition, we could also require ruby here, and run "make acceptance".
+ cd test/acceptance
+ ruby acceptance_test.rb
}
package() {
- cd "$builddir"
make install PREFIX="/usr" DESTDIR="$pkgdir"
}