aboutsummaryrefslogtreecommitdiffstats
path: root/testing/getmail
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-05-18 11:50:36 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-18 13:26:19 +0000
commit63156ee9bf1f72e0ff7695f30251a26f71d808b8 (patch)
tree6c0d101713163eb80ca675e29eba40562185820a /testing/getmail
parentbd40c7b03942af9b6462f95e43938b7d30ef6f7d (diff)
downloadaports-63156ee9bf1f72e0ff7695f30251a26f71d808b8.tar.bz2
aports-63156ee9bf1f72e0ff7695f30251a26f71d808b8.tar.xz
testing/getmail: new aport
getmail is a mail retriever designed to allow you to get your mail from one or more mail accounts on various mail servers to your local machine for reading with a minimum of fuss. getmail is designed to be secure, flexible, reliable, and easy-to-use. http://pyropus.ca/software/getmail/
Diffstat (limited to 'testing/getmail')
-rw-r--r--testing/getmail/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/getmail/APKBUILD b/testing/getmail/APKBUILD
new file mode 100644
index 0000000000..f29156c177
--- /dev/null
+++ b/testing/getmail/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=getmail
+pkgver=4.26.0
+pkgrel=0
+pkgdesc="POP3, IMAP4, and SDPS mail retriever with Maildir delivery"
+url="http://pyropus.ca/software/getmail/"
+arch="noarch"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://pyropus.ca/software/getmail/old-versions/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a45622b355b649071a337c661533453a getmail-4.26.0.tar.gz"