aboutsummaryrefslogtreecommitdiffstats
path: root/testing/glmark2
diff options
context:
space:
mode:
authorDanct12 <danct12@disroot.org>2020-05-06 11:28:04 +0700
committerRasmus Thomsen <oss@cogitri.dev>2020-05-06 09:30:47 +0000
commit6e8b4554ca290ab243664488befb8b00b4af890f (patch)
tree72bc7d331370d43b1a06cd6508a1d8f557e9876f /testing/glmark2
parent38f83f4eba445b1cf95edf1381f59eee377e2ec5 (diff)
downloadaports-6e8b4554ca290ab243664488befb8b00b4af890f.tar.bz2
aports-6e8b4554ca290ab243664488befb8b00b4af890f.tar.xz
testing/glmark2: new aport
GLmark is a OpenGL(ES) 2.0 benchmarking tool. Signed-off-by: Danct12 <danct12@disroot.org>
Diffstat (limited to 'testing/glmark2')
-rw-r--r--testing/glmark2/APKBUILD32
-rw-r--r--testing/glmark2/py3-compat.patch22
2 files changed, 54 insertions, 0 deletions
diff --git a/testing/glmark2/APKBUILD b/testing/glmark2/APKBUILD
new file mode 100644
index 0000000000..49ac865641
--- /dev/null
+++ b/testing/glmark2/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Danct12 <danct12@disroot.org>
+# Maintainer: Danct12 <danct12@disroot.org>
+pkgname=glmark2
+pkgver=2020.04
+pkgrel=0
+pkgdesc="OpenGL 2.0 and ES 2.0 benchmark"
+url="https://github.com/glmark2/glmark2"
+arch="all"
+license="GPL-3.0-or-later"
+subpackages="$pkgname-doc"
+makedepends="python3 eudev-dev libjpeg-turbo-dev libpng-dev mesa-dev wayland-dev wayland-protocols"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/glmark2/glmark2/archive/$pkgver.tar.gz
+ py3-compat.patch
+ "
+options="!check" # no testsuite
+
+prepare() {
+ default_prepare
+ python3 ./waf configure --prefix=/usr --with-flavors drm-gl,drm-glesv2,wayland-gl,wayland-glesv2,x11-gl,x11-glesv2
+}
+
+build() {
+ python3 ./waf
+}
+
+package() {
+ python3 ./waf install --destdir="$pkgdir"
+}
+
+sha512sums="68d72403ab5c6b4562faf43ae94159e4b8dcb697f62ea9dc3eac5634a3e22b19e14e215a081ae2a39e5db77e6f0f40d5ceb0281962600526d08121a197105a80 glmark2-2020.04.tar.gz
+f03c39b1bc26d3a38a54f1cf029d4714d502e4f4be8e89a9a86aa116c16f07226714f73e00e99eab9529f20532d47a734f9ebab71bc02d7829a986c91f3f2dab py3-compat.patch"
diff --git a/testing/glmark2/py3-compat.patch b/testing/glmark2/py3-compat.patch
new file mode 100644
index 0000000000..825fba54ec
--- /dev/null
+++ b/testing/glmark2/py3-compat.patch
@@ -0,0 +1,22 @@
+From 06e4728ba7312efa0fd595e30745e60ce88f1a4f Mon Sep 17 00:00:00 2001
+From: Marvin Schmidt <marv@exherbo.org>
+Date: Sun, 3 May 2020 18:20:05 +0200
+Subject: [PATCH] Build: Fix Python 3 incompatibility
+
+---
+ wscript | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/wscript b/wscript
+index aefde70..e09fa78 100644
+--- a/wscript
++++ b/wscript
+@@ -20,7 +20,7 @@ FLAVORS = {
+ 'x11-gl' : 'glmark2',
+ 'x11-glesv2' : 'glmark2-es2',
+ }
+-FLAVORS_STR = ", ".join(sorted(FLAVORS.keys() + ['all-linux', 'all-win32']))
++FLAVORS_STR = ", ".join(sorted(list(FLAVORS) + ['all-linux', 'all-win32']))
+
+ def linux_flavors():
+ return [f for f in FLAVORS.keys() if not f.startswith('win32')]