aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-pkac
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 09:19:09 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 09:19:09 +0000
commit191a4972c9c85c4262e65906f09192b50a2122a8 (patch)
treed0b5b72a85432ea01ddbed06785a5f7ed6343b0d /testing/go-pkac
parent3bfe36cb3c815a652d206b708e5e56118e8c2454 (diff)
downloadaports-191a4972c9c85c4262e65906f09192b50a2122a8.tar.bz2
aports-191a4972c9c85c4262e65906f09192b50a2122a8.tar.xz
testing/go-pkac: upgrade to 0.1.0
Modernize APKBUILD, update license, disable check(), take maintainership
Diffstat (limited to 'testing/go-pkac')
-rw-r--r--testing/go-pkac/APKBUILD34
1 files changed, 12 insertions, 22 deletions
diff --git a/testing/go-pkac/APKBUILD b/testing/go-pkac/APKBUILD
index 51da2ab872..12ad513ad6 100644
--- a/testing/go-pkac/APKBUILD
+++ b/testing/go-pkac/APKBUILD
@@ -1,34 +1,26 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=go-pkac
-_realname=pkac
+_pkgname=pkac
_vendor="longsleep"
-pkgver=0.0.1
+pkgver=0.1.0
pkgrel=0
pkgdesc="SPKAC/PKAC HTML keygen element data decoding for Go"
-url="https://github.com/$_vendor/$_realname"
+url="https://github.com/$_vendor/$_pkgname"
arch="noarch"
-license="Custom"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=
+license="BSD-3-Clause"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/$_vendor/$_realname/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$_realname-$pkgver
-
-prepare() {
- cd "$builddir"
-}
+options="!check" # no testsuite
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_vendor/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
+ return 0
}
package() {
cd "$builddir"
mkdir -p "$pkgdir"/usr/share/doc/$_vendor/$pkgname \
- "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
for file in \
LICENSE \
README.md \
@@ -37,9 +29,7 @@ package() {
; do \
test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$pkgname
done
- mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname || return 1
+ mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
}
-md5sums="a8741ff729d9ca437c3993e1241a5f3a go-pkac-0.0.1.tar.gz"
-sha256sums="bf811903e873cf8837ef9e3ea1fe291627d40067035cad1f1ecc159d1f102782 go-pkac-0.0.1.tar.gz"
-sha512sums="e3b6e754f7666b08c9903225241f01f3f644942eca078f52a7989ba4b96b27ccfc620aef8c17e59c74cd234dd9b3fcf840ce0ef81a3aacfaf581153b0ecbd743 go-pkac-0.0.1.tar.gz"
+sha512sums="0c279736f116dc585ae2475cb727915c88b2424efa219a115b33f5c2da2272caa8faab0eee93f8473c749d5dea1a10f1ab32b10f7e17a69bf11380a1b066c99a go-pkac-0.1.0.tar.gz"