aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-sloth
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-01-03 14:58:28 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-01-03 15:22:00 +0000
commit0535789ab39df742d25500efbb177f94a6f9fd89 (patch)
tree9cafe61f4d325a7368511902e39c06e0a5fb4599 /testing/go-sloth
parent4a8a545efb5090b93f909e8dfa0e9007e4f5d31f (diff)
downloadaports-0535789ab39df742d25500efbb177f94a6f9fd89.tar.bz2
aports-0535789ab39df742d25500efbb177f94a6f9fd89.tar.xz
testing/go-sloth: new aport
A tiny REST framework for Go
Diffstat (limited to 'testing/go-sloth')
-rw-r--r--testing/go-sloth/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/go-sloth/APKBUILD b/testing/go-sloth/APKBUILD
new file mode 100644
index 0000000000..c589438578
--- /dev/null
+++ b/testing/go-sloth/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=go-sloth
+_realname=sloth
+_vendor="strukturag"
+pkgver=0.9.2
+pkgrel=0
+pkgdesc="A tiny REST framework for Go"
+url="https://github.com/$_vendor/$_realname"
+arch="noarch"
+license="Custom"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_vendor/$_realname/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/${_realname}-$pkgver
+
+
+prepare() {
+ cd "$builddir"
+}
+
+build() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/share/doc/$_vendor/$pkgname \
+ "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ for file in \
+ LICENSE \
+ README.md \
+ COPYRIGHT \
+ AUTHORS \
+ ; do \
+ test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$pkgname
+ done
+ mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname || return 1
+}
+
+md5sums="4a40690a4ca65f65f452007a57c26a64 go-sloth-0.9.2.tar.gz"
+sha256sums="4a4757d85eae8d84b5da1579267b2f80ffd38044db665718b5b6522c9748de5c go-sloth-0.9.2.tar.gz"
+sha512sums="2d7550e2cd0f7ae259567a5611886bb70132ca0bf5fc7e85f80f6cb31233cc45120cd8feb862666f31b43fd95de83713e7cfc38687074ea6659b9dd6dbd08332 go-sloth-0.9.2.tar.gz"