aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-spreed-turnservicecli
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 10:47:06 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 10:48:13 +0000
commit4c4e7a262b750696715b2316561e988c2adf41aa (patch)
tree2994bd551f45e585ea3481d88459c73458b5d479 /testing/go-spreed-turnservicecli
parenta2155f82f3c8ca1f961774c6a1340535d444c0a3 (diff)
downloadaports-4c4e7a262b750696715b2316561e988c2adf41aa.tar.bz2
aports-4c4e7a262b750696715b2316561e988c2adf41aa.tar.xz
testing/go-spreed-turnservicecli: modernize APKBUILD, update license, disable check()
Take maintainership
Diffstat (limited to 'testing/go-spreed-turnservicecli')
-rw-r--r--testing/go-spreed-turnservicecli/APKBUILD34
1 files changed, 12 insertions, 22 deletions
diff --git a/testing/go-spreed-turnservicecli/APKBUILD b/testing/go-spreed-turnservicecli/APKBUILD
index 8a98db5e82..c11eaa6a6a 100644
--- a/testing/go-spreed-turnservicecli/APKBUILD
+++ b/testing/go-spreed-turnservicecli/APKBUILD
@@ -1,45 +1,35 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=go-spreed-turnservicecli
-_realname=spreed-turnservicecli
+_pkgname=spreed-turnservicecli
_vendor="strukturag"
pkgver=0.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="TURN service client implementation for Go"
-url="https://github.com/$_vendor/$_realname"
+url="https://github.com/$_vendor/$_pkgname"
arch="noarch"
-license="Custom"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=
+license="AGPL-3.0-only"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/$_vendor/$_realname/archive/v$pkgver.tar.gz"
-builddir="$srcdir"/$_realname-$pkgver
-
-prepare() {
- cd "$builddir"
-}
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_vendor/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
+ return 0
}
package() {
cd "$builddir"
mkdir -p "$pkgdir"/usr/share/doc/$_vendor/$pkgname \
- "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
for file in \
LICENSE \
- README.md \
+ README.* \
COPYRIGHT \
AUTHORS \
; do \
test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$pkgname
done
- mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname || return 1
+ mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
}
-md5sums="0571eea14d8e214fe450e9660c4de26b go-spreed-turnservicecli-0.1.0.tar.gz"
-sha256sums="543350602e54e7235ba5142696e4cafe38724908a212c38746b599748fc7c172 go-spreed-turnservicecli-0.1.0.tar.gz"
sha512sums="a9b82985154c8d0ffa85c684204650fd28af4e868f3c20c1f1524144ab208adb7199f694c3a0787f09994485ad64f857321d41773f80ac18f22161f01273459d go-spreed-turnservicecli-0.1.0.tar.gz"