aboutsummaryrefslogtreecommitdiffstats
path: root/testing/googler
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-24 00:13:23 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-24 09:34:12 -0300
commit248c4d88989a19c755458620b6855d04cd9d8aec (patch)
tree93c6174f109178f01eec46e9ecc76a14a7d528b9 /testing/googler
parent7072bcb329c81ffd441b52b200e57478b77f2d26 (diff)
downloadaports-248c4d88989a19c755458620b6855d04cd9d8aec.tar.bz2
aports-248c4d88989a19c755458620b6855d04cd9d8aec.tar.xz
testing/googler: upgrade to 3.9
Diffstat (limited to 'testing/googler')
-rw-r--r--testing/googler/APKBUILD42
1 files changed, 17 insertions, 25 deletions
diff --git a/testing/googler/APKBUILD b/testing/googler/APKBUILD
index 7fb435501b..84cb051efe 100644
--- a/testing/googler/APKBUILD
+++ b/testing/googler/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Ivan Tham <pickfire@riseup.net>
# Maintainer: Ivan Tham <pickfire@riseup.net>
pkgname=googler
-pkgver=3.8
+pkgver=3.9
pkgrel=0
pkgdesc="Google Search, Google Site Search, Google News from the terminal"
url="https://github.com/jarun/googler"
@@ -14,48 +14,40 @@ subpackages="$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
"
source="$pkgname-$pkgver.tar.gz::https://github.com/jarun/googler/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
make disable-self-upgrade
}
-check() {
- cd "$builddir"
- ./googler --help > /dev/null
-}
-
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir" PREFIX=/usr
}
bashcomp() {
- pkgdesc="Bash completion for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+ pkgdesc="Bash completion for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
- install -Dm644 "$builddir"/auto-completion/bash/* \
- "$subpkgdir"/usr/share/bash-completion/completions/
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
+ install -Dm644 "$builddir"/auto-completion/bash/* \
+ "$subpkgdir"/usr/share/bash-completion/completions/
}
fishcomp() {
- pkgdesc="Fish completion for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel fish"
+ pkgdesc="Fish completion for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
- mkdir -p "$subpkgdir"/usr/share/fish/completions/
- install -Dm644 "$builddir"/auto-completion/fish/* \
- "$subpkgdir"/usr/share/fish/completions/
+ mkdir -p "$subpkgdir"/usr/share/fish/completions/
+ install -Dm644 "$builddir"/auto-completion/fish/* \
+ "$subpkgdir"/usr/share/fish/completions/
}
zshcomp() {
- pkgdesc="Zsh completion for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
+ pkgdesc="Zsh completion for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
- mkdir -p "$subpkgdir"/usr/share/zsh/site-functions
- install -Dm644 "$builddir"/auto-completion/zsh/* \
- "$subpkgdir"/usr/share/zsh/site-functions/
+ mkdir -p "$subpkgdir"/usr/share/zsh/site-functions
+ install -Dm644 "$builddir"/auto-completion/zsh/* \
+ "$subpkgdir"/usr/share/zsh/site-functions/
}
-sha512sums="39e286236dca12147b31dc218b2a0b58364946f6b30734f84f8116efaa3a8a7fa61cb4d408080d1962498d24d4907bb225a3a4573f416e2e68c52f0a120b233d googler-3.8.tar.gz"
+sha512sums="b11bcc87951fef8b1719d5fd8b2406c1a4f03fd2431eaaed1ce1dcc8451162e1b5f14b779858a9fa494e641f5ee92892878ae29fff2b4af0f09270a0076dff11 googler-3.9.tar.gz"