aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gosu
diff options
context:
space:
mode:
authorDavid Huffman <storedbox@outlook.com>2016-01-16 09:10:40 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2016-01-21 15:14:36 +0000
commit949c1ec300111c97f70152fcc268c1d60924fbc8 (patch)
tree2da72dd6bdfdcde91934a25b548a9367f3d6e68f /testing/gosu
parent2aed621e02bb4948a7ff4f463f726941ceb40d4b (diff)
downloadaports-949c1ec300111c97f70152fcc268c1d60924fbc8.tar.bz2
aports-949c1ec300111c97f70152fcc268c1d60924fbc8.tar.xz
testing/gosu: new aport
https://github.com/tianon/gosu Simple Go-based setuid+setgid+setgroups+exec
Diffstat (limited to 'testing/gosu')
-rw-r--r--testing/gosu/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/gosu/APKBUILD b/testing/gosu/APKBUILD
new file mode 100644
index 0000000000..0b347c998e
--- /dev/null
+++ b/testing/gosu/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: David Huffman <storedbox@outlook.com>
+# Maintainer: David Huffman <storedbox@outlook.com>
+pkgname=gosu
+pkgver=1.7
+pkgrel=0
+pkgdesc="Simple Go-based setuid+setgid+setgroups+exec"
+url="https://github.com/tianon/gosu"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev=""
+makedepends="$depends_dev go"
+install=""
+subpackages=""
+source="https://github.com/tianon/gosu/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir/github.com/tianon/$pkgname"
+prepare() {
+ mkdir -p "$_builddir"
+ find "$srcdir" -name '*.go' -type f -exec mv {} "$_builddir" \+
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ export GOPATH="$startdir"
+ go get || return 1
+ go build -v || return 1
+}
+
+package() {
+ cd "$_builddir"
+ local bindir="$pkgdir/usr/bin"
+ mkdir -p "$bindir" || return 1
+ cp gosu "$bindir" || return 1
+}
+
+md5sums="84aa02fc06fcbb81834a7466bf2778e1 gosu-1.7.tar.gz"
+sha256sums="a010c7e34de69bfc2aa4b104a73c63d09e51caa6a5c8d75e836be6c692e9aae1 gosu-1.7.tar.gz"
+sha512sums="745afb75735321f2e239fe93fc947f969bda76dd9869cbf25850e7d7f4f271e5e00afceaead7da11063302e5af2b143ca42282b1a5907de99da3e90cf7197ed6 gosu-1.7.tar.gz"