aboutsummaryrefslogtreecommitdiffstats
path: root/testing/grub
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-09-13 10:49:11 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-09-13 10:52:18 +0200
commit18933df139abc4bc2aed9363e7524846bec79dfa (patch)
treec4c7a66ca8f3df221500cd244ede11af34b73262 /testing/grub
parent315bf29a27f672f9a6c8fb4658969856c6910d30 (diff)
downloadaports-18933df139abc4bc2aed9363e7524846bec79dfa.tar.bz2
aports-18933df139abc4bc2aed9363e7524846bec79dfa.tar.xz
testing/grub: enable on x86_64
currently gcc has an issue with no-pic on x86_84
Diffstat (limited to 'testing/grub')
-rw-r--r--testing/grub/APKBUILD18
-rw-r--r--testing/grub/fix-gcc-no-pie-specs.patch20
2 files changed, 32 insertions, 6 deletions
diff --git a/testing/grub/APKBUILD b/testing/grub/APKBUILD
index 0b23ff60ff..b555579f67 100644
--- a/testing/grub/APKBUILD
+++ b/testing/grub/APKBUILD
@@ -6,21 +6,24 @@ pkgver=2.02_beta3
pkgrel=0
pkgdesc="Bootloader with support for Linux, Multiboot and more"
url="https://www.gnu.org/software/grub/"
-arch="all !x86_64"
+arch="all"
license="GPLv3+"
depends=""
depends_dev=""
-makedepends="$depends_dev bison flex linux-headers xz-dev gnu-efi-dev lvm2-dev
+makedepends="$depends_dev bison flex linux-headers xz-dev lvm2-dev
automake autoconf libtool"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="ftp://alpha.gnu.org/gnu/grub/grub-$_ver.tar.xz
- 2.02_beta3-gcc6-ld-no-pie.patch"
+ 2.02_beta3-gcc6-ld-no-pie.patch
+ fix-gcc-no-pie-specs.patch
+ "
builddir="$srcdir/grub-$_ver"
build() {
cd "$builddir"
autoreconf -vif
+ #export CFLAGS="$CFLAGS -no-pie"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,8 +42,11 @@ package() {
}
md5sums="ab399fc6f74a97d66ff77f04b743149c grub-2.02~beta3.tar.xz
-7a09f166141e2a57f1829dd6cf1424fa 2.02_beta3-gcc6-ld-no-pie.patch"
+7a09f166141e2a57f1829dd6cf1424fa 2.02_beta3-gcc6-ld-no-pie.patch
+632f1e9dee0f8a4a52e592cb29cdf8cc fix-gcc-no-pie-specs.patch"
sha256sums="30ec3d555e52a702c3eef449872ef874eff28b320f40b55ffc47f70db8e5ada1 grub-2.02~beta3.tar.xz
-14912f087e047259e803be020c0506d9865c1507ae34683c6668b8d4a140c93b 2.02_beta3-gcc6-ld-no-pie.patch"
+14912f087e047259e803be020c0506d9865c1507ae34683c6668b8d4a140c93b 2.02_beta3-gcc6-ld-no-pie.patch
+eaa876af6b6253c2ca98a03201b98b0e0a27b9acc120b7937c9292882f2f0e0b fix-gcc-no-pie-specs.patch"
sha512sums="4a530efef4dae45f4046cf3550563f14acb24d25cb88d5e06c93953ca5b1eec115118c6860233a9f627edcddae2571e5d6b867b70ff9dd5c184c9fef83ef7e11 grub-2.02~beta3.tar.xz
-fc15c95bf26b28eee3b5a0d8e5fac538445179cea19a8657cd360e37dd5a95010ea2b899d1e4f3692b778a71f79526539ad1c741f028186f0daf135ee1678da0 2.02_beta3-gcc6-ld-no-pie.patch"
+fc15c95bf26b28eee3b5a0d8e5fac538445179cea19a8657cd360e37dd5a95010ea2b899d1e4f3692b778a71f79526539ad1c741f028186f0daf135ee1678da0 2.02_beta3-gcc6-ld-no-pie.patch
+b9eab870006ab7842e0af27171d3b66fea10835d3fd4e606f241a9898aa28bfc4c1cdf59cece8ad50d2e284a44cba74eb0f390ac29627518f86257a8d586976e fix-gcc-no-pie-specs.patch"
diff --git a/testing/grub/fix-gcc-no-pie-specs.patch b/testing/grub/fix-gcc-no-pie-specs.patch
new file mode 100644
index 0000000000..b14c0be3cc
--- /dev/null
+++ b/testing/grub/fix-gcc-no-pie-specs.patch
@@ -0,0 +1,20 @@
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -1092,7 +1092,7 @@
+ if test x"$grub_cv_target_cc_efiemu64_link_format" = xunknown; then
+ efiemu_excuse="no suitable link format for efiemu64 found"
+ else
+- EFIEMU64_LINK_FORMAT="-Wl,$grub_cv_target_cc_efiemu64_link_format"
++ EFIEMU64_LINK_FORMAT="-Wl,$grub_cv_target_cc_efiemu64_link_format -no-pie"
+ fi
+ fi
+ if test x"$enable_efiemu" = xyes && test x"$efiemu_excuse" != x ; then
+@@ -1188,7 +1188,7 @@
+ [# Need that, because some distributions ship compilers that include
+ # `-fPIE' and '-pie' in the default specs.
+ if [ x"$pie_possible" = xyes ]; then
+- TARGET_CFLAGS="$TARGET_CFLAGS -fno-PIE"
++ TARGET_CFLAGS="$TARGET_CFLAGS -no-pie"
+ fi
+ if [ x"$nopie_possible" = xyes ] && [ x"$pie_possible" = xyes ]; then
+ TARGET_LDFLAGS="$TARGET_LDFLAGS -no-pie"