aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gx
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-09 16:56:25 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-09 17:13:28 -0300
commit981d5bd50e21c967b279107d20282c3f74e63ae7 (patch)
tree08a4ba661d594d132ae0e7f922a6d83bd4c3e36a /testing/gx
parent76590099109da5b04b3e1a977468625cb34d7d6b (diff)
downloadaports-981d5bd50e21c967b279107d20282c3f74e63ae7.tar.bz2
aports-981d5bd50e21c967b279107d20282c3f74e63ae7.tar.xz
testing/gx: upgrade to 0.14.3
Diffstat (limited to 'testing/gx')
-rw-r--r--testing/gx/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/testing/gx/APKBUILD b/testing/gx/APKBUILD
index 4dd474bc93..8f4a7ed61f 100644
--- a/testing/gx/APKBUILD
+++ b/testing/gx/APKBUILD
@@ -1,18 +1,19 @@
# Contributor: Oleg Titov <oleg.titov@gmail.com>
# Maintainer: Oleg Titov <oleg.titov@gmail.com>
pkgname=gx
-pkgver=0.14.2
-pkgrel=1
+pkgver=0.14.3
+pkgrel=0
pkgdesc="Packaging tool build around the distributed, content addressed filesystem IPFS"
url="https://github.com/whyrusleeping/gx"
arch="all"
license="MIT"
-options="!check" # Test suite issues
+options="!check chmod-clean" # Test suite issues
makedepends="git glide go"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/whyrusleeping/$pkgname/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/whyrusleeping/gx/archive/v$pkgver.tar.gz
glide.yaml
- glide.lock"
+ glide.lock
+ "
builddir="$srcdir/src/github.com/whyrusleeping/$pkgname"
prepare() {
@@ -21,7 +22,6 @@ prepare() {
mkdir -p $(dirname $builddir)
mv "$srcdir"/$pkgname-$pkgver "$builddir"/
- cd "$builddir"
cp "$srcdir"/glide.yaml "$srcdir"/glide.lock .
glide install --skip-test
@@ -33,8 +33,8 @@ build() {
}
package() {
- install -Dm 755 gx "${pkgdir}/usr/bin/gx"
- install -Dm 644 -t "${pkgdir}/usr/share/licenses/gx" LICENSE
+ install -Dm 755 gx "$pkgdir/usr/bin/gx"
+ install -Dm 644 -t "$pkgdir/usr/share/licenses/gx" LICENSE
}
glide_init() {
@@ -48,6 +48,6 @@ glide_init() {
cd "$startdir" && abuild checksum clean
}
-sha512sums="60d0dfd330181f82d69a6018c5ac7a3d1cd5a3dd137dd93dba01b6ab1374a961eceb377d4ff7c69753e6fc80fcbcc3f780bbb57cc19ec0cee961cdba787ef87d gx-0.14.2.tar.gz
+sha512sums="14280680254aea69b1295e625788b39404a77defdcdd47399529ee818695965c06c6001de8adb0a44f641e66f9386ca9da3fc2c56a038c4b96a8ddd6252c3d49 gx-0.14.3.tar.gz
b1ac1cdd2ed760072cab4d63876ad711407bc467bee37ee3740b477f1071a13e0086afef99d15cb9267634ca8496aa92d1a1b399fc99f0479336433c9212810d glide.yaml
6ddf9614c4244258191f0ba7fe1e41d5f84981795a71edc1f3d117f7ec72f1928d887a2dd9aecdb78c7cdac6c04eedf09e2e0af79f6049c337e122b5c7ac5ee7 glide.lock"