aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hamlib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-24 16:32:34 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-24 18:00:11 -0300
commit8b8b7d2339c0cf5e0d83b02683b0fc7aac657d8d (patch)
treed7447d13043912b2a546305f9f019481a1c5dd2e /testing/hamlib
parentc67bc1fa3ea6538f0b1dc66fa7cd6f3d0a7a50c5 (diff)
downloadaports-8b8b7d2339c0cf5e0d83b02683b0fc7aac657d8d.tar.bz2
aports-8b8b7d2339c0cf5e0d83b02683b0fc7aac657d8d.tar.xz
testing/hamlib: upgrade to 3.3
Diffstat (limited to 'testing/hamlib')
-rw-r--r--testing/hamlib/APKBUILD29
1 files changed, 12 insertions, 17 deletions
diff --git a/testing/hamlib/APKBUILD b/testing/hamlib/APKBUILD
index 9832a0aca8..c6e8a78a3b 100644
--- a/testing/hamlib/APKBUILD
+++ b/testing/hamlib/APKBUILD
@@ -1,23 +1,20 @@
# Contributor: Bradford D. Boyle <bradford.d.boyle@gmail.com>
# Maintainer: Bradford D. Boyle <bradford.d.boyle@gmail.com>
pkgname=hamlib
-pkgver=3.0
-pkgrel=1
+pkgver=3.3
+pkgrel=0
pkgdesc="Library to control radio transceivers and receivers"
url="http://www.hamlib.org/"
arch="all"
license="LGPL-2.0-or-later"
-depends=""
-depends_dev=""
-makedepends="$depends_dev linux-headers perl-dev python-dev swig tcl-dev chrpath"
-install=""
+makedepends="linux-headers perl-dev python-dev swig tcl-dev chrpath libusb-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-perl $pkgname-python $pkgname-tcl"
-source="https://downloads.sourceforge.net/project/hamlib/hamlib/3.0/hamlib-3.0.tar.gz"
+source="https://downloads.sourceforge.net/project/hamlib/hamlib/$pkgver/hamlib-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$builddir"
- ./configure --prefix=/usr --sbindir=/usr/bin \
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
--with-perl-binding \
--with-python-binding \
--with-tcl-binding
@@ -25,10 +22,10 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
-
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ rm -f "$pkgdir"/usr/lib/*.a
+ rm -f "$pkgdir"/usr/lib/python2.7/site-packages/_Hamlib.a
+ rm -f "$pkgdir"/usr/lib/tcl8.6/Hamlib/hamlibtcl.a
}
perl() {
@@ -56,9 +53,7 @@ python() {
tcl() {
mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/tcl "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/tcl8.6 "$subpkgdir"/usr/lib/
}
-md5sums="ffe192ff83c5935966367efe5bb33334 hamlib-3.0.tar.gz"
-sha256sums="bc16546161a47e21a44a710a40aeb0bce478f112bffcc4f253eb27e150f1c21e hamlib-3.0.tar.gz"
-sha512sums="16ac66ab91d44c364054aa6ba8292a6538886744d83a83eb0887f55407f836e1d4a402cc7a41576594bea8100c2eefa26bae212f767a68b2a4db7a709166cbd2 hamlib-3.0.tar.gz"
+sha512sums="4cf6c94d0238c8a13aed09413b3f4a027c8ded07f8840cdb2b9d38b39b6395a4a88a8105257015345f6de0658ab8c60292d11a9de3e16a493e153637af630a80 hamlib-3.3.tar.gz"