aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hardinfo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-29 16:23:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-29 16:26:35 +0000
commitfd0cf32e80cc193c56fabc8639e91bf022bc8b06 (patch)
tree810696eae012171fbc3d4949629d2d123e3bbedd /testing/hardinfo
parent0652de5a797997bc087c9e0065184a127e7ddac2 (diff)
downloadaports-fd0cf32e80cc193c56fabc8639e91bf022bc8b06.tar.bz2
aports-fd0cf32e80cc193c56fabc8639e91bf022bc8b06.tar.xz
testing/hardinfo: added support for alpine OS release
Diffstat (limited to 'testing/hardinfo')
-rw-r--r--testing/hardinfo/APKBUILD11
-rw-r--r--testing/hardinfo/hardinfo-alpine.patch10
2 files changed, 17 insertions, 4 deletions
diff --git a/testing/hardinfo/APKBUILD b/testing/hardinfo/APKBUILD
index 30b5794916..8b6db2bf40 100644
--- a/testing/hardinfo/APKBUILD
+++ b/testing/hardinfo/APKBUILD
@@ -1,19 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hardinfo
pkgver=0.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A system information and benchmark tool."
url="http://hardinfo.berlios.de/wiki/index.php/Main_Page"
license="GPL-2"
makedepends="gtk+-dev libsoup-dev>=2.4.0 gnutls-dev>=2.4.1"
depends=
source="http://download.berlios.de/$pkgname/$pkgname-$pkgver.tar.bz2
- fixsensors.patch"
+ fixsensors.patch
+ hardinfo-alpine.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- patch -p1 < "$srcdir"/fixsensors.patch || return 1
+ patch -p1 -i "$srcdir"/fixsensors.patch || return 1
+ patch -p1 -i "$srcdir"/hardinfo-alpine.patch || return 1
# configure scrip says bash but bb ash works just fine
sed -i -e '1,1s/bash/sh/' configure
}
@@ -31,4 +33,5 @@ package() {
echo "Alpine Linux" > "$pkgdir"/etc/hardinfo.distro
}
md5sums="6fb38992e140f2fab16518ae1f38e188 hardinfo-0.5.1.tar.bz2
-05c212db07b9f152cdea052ff7bb28fa fixsensors.patch"
+05c212db07b9f152cdea052ff7bb28fa fixsensors.patch
+ae8d38e5b35fb2c9c5f425dde3ba27cb hardinfo-alpine.patch"
diff --git a/testing/hardinfo/hardinfo-alpine.patch b/testing/hardinfo/hardinfo-alpine.patch
new file mode 100644
index 0000000000..279aa5d539
--- /dev/null
+++ b/testing/hardinfo/hardinfo-alpine.patch
@@ -0,0 +1,10 @@
+--- ./computer.h.orig
++++ ./computer.h
+@@ -23,6 +23,7 @@
+ static struct {
+ gchar *file, *codename;
+ } distro_db[] = {
++ { DB_PREFIX "alpine-version", "al" },
+ { DB_PREFIX "debian_version", "deb" },
+ { DB_PREFIX "slackware-version", "slk" },
+ { DB_PREFIX "mandrake-release", "mdk" },