aboutsummaryrefslogtreecommitdiffstats
path: root/testing/haxe
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-10 02:04:52 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-10 02:17:26 +0100
commitc4e0da55788a1dd721421fbb816d634590cc2298 (patch)
treeacb7ee104946f285d2237aba2d514d71dbcb9b92 /testing/haxe
parentaf8c31f0b57a93473920ac27aa5c7603b0550c84 (diff)
downloadaports-c4e0da55788a1dd721421fbb816d634590cc2298.tar.bz2
aports-c4e0da55788a1dd721421fbb816d634590cc2298.tar.xz
testing/haxe: modernize abuild, fix code-style
Diffstat (limited to 'testing/haxe')
-rw-r--r--testing/haxe/APKBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/testing/haxe/APKBUILD b/testing/haxe/APKBUILD
index e5d6a4e8a3..8cd0cb8f6d 100644
--- a/testing/haxe/APKBUILD
+++ b/testing/haxe/APKBUILD
@@ -8,30 +8,27 @@ pkgdesc="Cross-platform toolkit and programming language"
url="https://haxe.org"
arch="x86_64 aarch64 ppc64le"
license="GPL MIT LGPL" # http://haxe.org/foundation/open-source.html
-depends=""
makedepends="ocaml-camlp4-dev ocaml neko-dev zlib-dev pcre-dev"
-options="!strip !makeflags"
-install=""
+options="!strip"
subpackages="$pkgname-doc"
# haxelib and ocamllibs are git submodules in the haxe repo.
# To get the commits, run `git submodule status`.
-_commit_haxelib="a494d8be523e26fcf875e2c33915808dc221e17a"
-_commit_ocamllibs="ab5be31c6dd1fcd761c2ba16c5d767bcf6792490"
-
-source="${pkgname}-${pkgver}.tar.gz::https://github.com/HaxeFoundation/haxe/archive/${pkgver}${_versuffix}.tar.gz
- haxelib-${_commit_haxelib}.tar.gz::https://github.com/HaxeFoundation/haxelib/archive/${_commit_haxelib}.tar.gz
- ocamllibs-${_commit_ocamllibs}.tar.gz::https://github.com/HaxeFoundation/ocamllibs/archive/${_commit_ocamllibs}.tar.gz
+_haxelib_rev="a494d8be523e26fcf875e2c33915808dc221e17a"
+_ocamllibs_rev="ab5be31c6dd1fcd761c2ba16c5d767bcf6792490"
+source="$pkgname-$pkgver.tar.gz::https://github.com/HaxeFoundation/haxe/archive/$pkgver$_versuffix.tar.gz
+ haxelib-$_haxelib_rev.tar.gz::https://github.com/HaxeFoundation/haxelib/archive/$_haxelib_rev.tar.gz
+ ocamllibs-$_ocamllibs_rev.tar.gz::https://github.com/HaxeFoundation/ocamllibs/archive/$_ocamllibs_rev.tar.gz
haxe.sh
"
+builddir="$srcdir/$pkgname-$pkgver$_versuffix"
-_builddir="$srcdir/$pkgname-$pkgver$_versuffix"
build() {
- cd "$_builddir"
+ cd "$builddir"
rmdir libs extra/haxelib_src
- mv "$srcdir"/haxelib-${_commit_haxelib} extra/haxelib_src
- mv "$srcdir"/ocamllibs-${_commit_ocamllibs} libs
+ mv "$srcdir"/haxelib-$_haxelib_rev extra/haxelib_src
+ mv "$srcdir"/ocamllibs-$_ocamllibs_rev libs
# Check to see if ocamlopt exists. If not, bytecompile everything.
command -v ocamlopt && make -j1 || make -j1 BYTECODE=1
@@ -39,20 +36,22 @@ build() {
}
check() {
- cd "$_builddir"
+ cd "$builddir"
./haxe -version
./haxelib version
}
package() {
- cd "$_builddir"
+ cd "$builddir"
+
install -d "$pkgdir"/usr/bin/ "$pkgdir"/usr/share/haxe/
install -m 755 haxe haxelib "$pkgdir"/usr/bin/
cp -rf std "$pkgdir"/usr/share/$pkgname/
install -Dm 644 extra/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
install -Dm 644 "$srcdir/haxe.sh" "$pkgdir/etc/profile.d/haxe.sh"
}
+
sha512sums="5b15018b714922aa362aeb9eab672ed76d32db73d06a0d976d14445bcd644661f2ff397016c41bdc2d092c513ad1458f3b377ca040c6c293f5d0711fdd6ba26d haxe-3.4.7.tar.gz
549d8eead2236a60747acc50a88129e587d52f7408342f657965d4f2faf638d62fd556f0d0d23a122ef03ee7164b966d6234f35dc81c1cebd703e254e2f57265 haxelib-a494d8be523e26fcf875e2c33915808dc221e17a.tar.gz
4aa501389bde4a9bef8e2e571dc012ccab10b98c3c37903ab5a262c2a9bec57fa4bee936222397c484ecefe917f28e98f6513bf83007cf89434f93e80ccc9d23 ocamllibs-ab5be31c6dd1fcd761c2ba16c5d767bcf6792490.tar.gz