aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hiawatha
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-12-23 19:23:38 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-12-24 06:03:39 +0000
commit2aae28d0f92ab5e4477edac4fc89a445a3e93570 (patch)
tree5c66504be9bec5f1401a01bc7e1e12cfbc006de3 /testing/hiawatha
parent84f1ba016af9f1cc1b1d23f1af8360a3b60703fd (diff)
downloadaports-2aae28d0f92ab5e4477edac4fc89a445a3e93570.tar.bz2
aports-2aae28d0f92ab5e4477edac4fc89a445a3e93570.tar.xz
testing/hiawatha: update init to new OpenRC style
init script updated to new OpenRC style 'need net' does not work in LXC containers so changed to 'need firewall' CMAKE option ENABLE_SSL was not used so removed. SSL connections still work without it.
Diffstat (limited to 'testing/hiawatha')
-rw-r--r--testing/hiawatha/APKBUILD13
-rw-r--r--testing/hiawatha/hiawatha.initd24
2 files changed, 11 insertions, 26 deletions
diff --git a/testing/hiawatha/APKBUILD b/testing/hiawatha/APKBUILD
index a4886a1332..887726caa4 100644
--- a/testing/hiawatha/APKBUILD
+++ b/testing/hiawatha/APKBUILD
@@ -3,7 +3,7 @@
pkgname=hiawatha
pkgver=10.0
-pkgrel=0
+pkgrel=1
pkgdesc='Secure and advanced webserver'
url='https://www.hiawatha-webserver.org/'
arch=all
@@ -26,7 +26,7 @@ prepare() {
}
build() {
cd "$srcdir"/$pkgname-$pkgver
-
+
cmake . -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_BINDIR=/usr/bin \
-DCMAKE_INSTALL_SBINDIR=/usr/sbin \
@@ -36,7 +36,6 @@ build() {
-DCONFIG_DIR=/etc/hiawatha \
-DLOG_DIR=/var/log/hiawatha \
-DPID_DIR=/var/run \
- -DENABLE_SSL=ON \
-DUSE_SYSTEM_MBEDTLS=ON \
-DWEBROOT_DIR=/var/www/hiawatha \
-DWORK_DIR=/var/lib/hiawatha || return 1
@@ -47,7 +46,7 @@ build() {
package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir/" install || return 1
-
+
sed -i 's|#ServerId = www-data|ServerId = nobody|' \
"$pkgdir"/etc/hiawatha/hiawatha.conf || return 1
sed -i 's|www-data|nobody|g' logrotate.d/hiawatha || return 1
@@ -60,11 +59,11 @@ package() {
}
md5sums="45400b720aaa3bb7663e4407f31fa4e6 hiawatha-10.0.tar.gz
-3bf112b794aa10debb93b5d892dfa425 hiawatha.initd
+cce590c3649d97b221a04c61329673aa hiawatha.initd
fb24fcbfa820a5b85f6c4c8a520a6920 hiawatha.conf.sample"
sha256sums="a39d1f771d818025538bd1231f42001bf29a1ebf55ce3d82afb7305cc251dd0e hiawatha-10.0.tar.gz
-c229c23712d71cf830a46f152f78a1aa726cf7c7cf9129ef7acfefb73483ae4c hiawatha.initd
+f28bc9e756e4a9fbc1da80f87667df0218acb85441585c7737e8a8cdd7017c54 hiawatha.initd
4671d2586cbe3cd6497b16ff422c6143cdab40641ef3c9c4988c478351a8f5e7 hiawatha.conf.sample"
sha512sums="ec73fb92fc6c22a7e6db2e10b75720fc97d3e5bb070222d21f532734c324d6b9de4bfc4ac348072ef1f7590d8082d90108b0cbe562481af1fd4f47bdc62450c1 hiawatha-10.0.tar.gz
-412ba77b765015dccf6804d0ef06c55590b7dbec0bf3beb18652e05ae0efc364061bb8892e9727d2a7ac5df93656b62bcb89448dfa4272ae6ae26c633523b17a hiawatha.initd
+f08ddf012fbead5b1e6724ebf7d58416abb557b6eb8c43064916921ffff1dbd1199491b36da12969b4c79715587d487a8d4d272bfb008c9dd59a103aac812571 hiawatha.initd
b2aad6d02e03a3e25dc6dc30deab4637a7de5448255b6b707363e8c71ae1029e669bacdb6b88889ec1aa804fe717560e872dc44d049127af9aa155a8895c8a60 hiawatha.conf.sample"
diff --git a/testing/hiawatha/hiawatha.initd b/testing/hiawatha/hiawatha.initd
index 9c04296a37..d2a7bb3c61 100644
--- a/testing/hiawatha/hiawatha.initd
+++ b/testing/hiawatha/hiawatha.initd
@@ -1,22 +1,8 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+#!/sbin/openrc-run
-depend() {
- need net
-}
+pidfile=/var/run/hiawatha.pid
+command=/usr/sbin/hiawatha
-start() {
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --exec "/usr/sbin/hiawatha" \
- --pidfile "/var/run/hiawatha.pid"
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --exec "/usr/sbin/hiawatha" \
- --pidfile "/var/run/hiawatha.pid"
- eend $?
+depend() {
+ need firewall
}