aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hiawatha
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-04-17 02:49:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-17 15:03:36 +0000
commit92a5f4f29a7fc872e5c243fa19e61a26873ce90b (patch)
treefd21d2194b3ca1e849a4c6ad8168e895b0f9ce97 /testing/hiawatha
parent63be96e632e9dfb08d26250934fb3de826357868 (diff)
downloadaports-92a5f4f29a7fc872e5c243fa19e61a26873ce90b.tar.bz2
aports-92a5f4f29a7fc872e5c243fa19e61a26873ce90b.tar.xz
testing/hiawatha: update to 10.6
https://www.hiawatha-webserver.org/changelog
Diffstat (limited to 'testing/hiawatha')
-rw-r--r--testing/hiawatha/APKBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/testing/hiawatha/APKBUILD b/testing/hiawatha/APKBUILD
index f25f8bb7bf..4e67a40119 100644
--- a/testing/hiawatha/APKBUILD
+++ b/testing/hiawatha/APKBUILD
@@ -2,13 +2,13 @@
# Contributor: Pascal Ernster <aur at hardfalcon dot net>
pkgname=hiawatha
-pkgver=10.5
+pkgver=10.6
pkgrel=0
pkgdesc='Secure and advanced webserver'
url='https://www.hiawatha-webserver.org/'
arch=all
license='GPL'
-options="suid"
+options="suid !check"
subpackages="$pkgname-doc"
makedepends="cmake libxml2-dev libxslt-dev mbedtls-dev"
source="https://hiawatha-webserver.org/files/$pkgname-$pkgver.tar.gz
@@ -29,26 +29,26 @@ build() {
-DPID_DIR=/var/run \
-DUSE_SYSTEM_MBEDTLS=ON \
-DWEBROOT_DIR=/var/www/hiawatha \
- -DWORK_DIR=/var/lib/hiawatha || return 1
+ -DWORK_DIR=/var/lib/hiawatha
- make || return 1
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir/" install || return 1
+ make DESTDIR="$pkgdir/" install
sed -i 's|#ServerId = www-data|ServerId = nobody|' \
- "$pkgdir"/etc/hiawatha/hiawatha.conf || return 1
- sed -i 's|www-data|nobody|g' logrotate.d/hiawatha || return 1
+ "$pkgdir"/etc/hiawatha/hiawatha.conf
+ sed -i 's|www-data|nobody|g' logrotate.d/hiawatha
install -Dm644 logrotate.d/hiawatha \
- "$pkgdir"/etc/logrotate.d/hiawatha || return 1
+ "$pkgdir"/etc/logrotate.d/hiawatha
install -Dm755 "$srcdir"/hiawatha.initd \
- "$pkgdir"/etc/init.d/hiawatha || return 1
+ "$pkgdir"/etc/init.d/hiawatha
install -Dm644 "$srcdir"/hiawatha.conf.sample \
- "$pkgdir"/usr/share/doc/hiawatha/hiawatha.conf.sample || return 1
+ "$pkgdir"/usr/share/doc/hiawatha/hiawatha.conf.sample
}
-sha512sums="556a2509cafcfe37b930cc517ecf708e5ed047784add83b600e17f7be85069504218844d416ec3d932fe35cd9ed2780192c8318d6da5e808b72a9ec1f017c8e1 hiawatha-10.5.tar.gz
+sha512sums="45199d2b986539d7fc1b3ff0b67e65dc8c9d41f5084b283574a2a1d9aa80524db4b57237672f0e75af5804a181a5989512342da1d920f1a80a5ecb352f1c5a36 hiawatha-10.6.tar.gz
4e1201110396e13b979948caae9c2dfb34f55398225d924164d2f0818b6778500ef3426b0ad358210ef7780289fbd752f7e006220941437fbcdd378746bf5a3d hiawatha.initd
b2aad6d02e03a3e25dc6dc30deab4637a7de5448255b6b707363e8c71ae1029e669bacdb6b88889ec1aa804fe717560e872dc44d049127af9aa155a8895c8a60 hiawatha.conf.sample"