aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hiawatha
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-15 13:26:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-15 13:26:43 +0000
commitb03ffffda63dd829c224cc7271024667e7ba68ae (patch)
treef11296841e47b4dd3d5572725c566fddc7be0dd2 /testing/hiawatha
parent71ae6527c2727f9575f037d378546ff4276d2309 (diff)
downloadaports-b03ffffda63dd829c224cc7271024667e7ba68ae.tar.bz2
aports-b03ffffda63dd829c224cc7271024667e7ba68ae.tar.xz
testing/hiawatha: upgrade to 9.15
Diffstat (limited to 'testing/hiawatha')
-rw-r--r--testing/hiawatha/APKBUILD14
-rw-r--r--testing/hiawatha/fix-mbedtls-underlinking.patch22
2 files changed, 5 insertions, 31 deletions
diff --git a/testing/hiawatha/APKBUILD b/testing/hiawatha/APKBUILD
index 77509a5f8d..6f05f5f857 100644
--- a/testing/hiawatha/APKBUILD
+++ b/testing/hiawatha/APKBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Kurt Marasco <celilo at lavabit dot com>
+# Maintainer: Kurt Marasco <celilo@lavabit.com>
# Contributor: Pascal Ernster <aur at hardfalcon dot net>
pkgname=hiawatha
-pkgver=9.14
+pkgver=9.15
pkgrel=0
pkgdesc='Secure and advanced webserver'
url='https://www.hiawatha-webserver.org/'
@@ -12,7 +12,6 @@ options="suid"
subpackages="$pkgname-doc"
makedepends="cmake libxml2-dev libxslt-dev mbedtls-dev"
source="https://hiawatha-webserver.org/files/$pkgname-$pkgver.tar.gz
- fix-mbedtls-underlinking.patch
hiawatha.initd
hiawatha.conf.sample"
@@ -60,15 +59,12 @@ package() {
"$pkgdir"/usr/share/doc/hiawatha/hiawatha.conf.sample || return 1
}
-md5sums="400aaf5af8b0060a91aaae7a462450ba hiawatha-9.14.tar.gz
-5028571283cb8eb87d2989a44daf01e8 fix-mbedtls-underlinking.patch
+md5sums="687e9583a65367077dd0e60967891564 hiawatha-9.15.tar.gz
3bf112b794aa10debb93b5d892dfa425 hiawatha.initd
fb24fcbfa820a5b85f6c4c8a520a6920 hiawatha.conf.sample"
-sha256sums="79c92587cd86a0461d952c99036f5615dacdcaccabe0a9a29359e6044d809bfa hiawatha-9.14.tar.gz
-fedcc9ce2ee104ec84c16b9f15f43e1ae91298f5418cb99bb19d7bd92ce4d5fa fix-mbedtls-underlinking.patch
+sha256sums="e9252133a1114095d1a9a89144b88828ee3b9754f435bd88270f7bf444dd9421 hiawatha-9.15.tar.gz
c229c23712d71cf830a46f152f78a1aa726cf7c7cf9129ef7acfefb73483ae4c hiawatha.initd
4671d2586cbe3cd6497b16ff422c6143cdab40641ef3c9c4988c478351a8f5e7 hiawatha.conf.sample"
-sha512sums="66ad77c132d34daa5eb597ce67d7b26581c59534e5cf83dd65f78567a9a1798030cd42fef2d612bd1935243db979a2ef1df873f01b0d0a009395ef3da1dca6e6 hiawatha-9.14.tar.gz
-8d074cd5ddb224a486f5429ecdd32ee46d1afa16c65dfb1254ed5cff1dd20e90857dabdd80f266d7f3938158ac41f446e6bb6a80524a69da9d270de24116d950 fix-mbedtls-underlinking.patch
+sha512sums="e5f0459475863c7cb2d15bdf2a9712f13c96ac450f349fd89e60fd600aad9010f25182aa6353a3014069a9798544a56ef79695918613946b63fecd3806b1982b hiawatha-9.15.tar.gz
412ba77b765015dccf6804d0ef06c55590b7dbec0bf3beb18652e05ae0efc364061bb8892e9727d2a7ac5df93656b62bcb89448dfa4272ae6ae26c633523b17a hiawatha.initd
b2aad6d02e03a3e25dc6dc30deab4637a7de5448255b6b707363e8c71ae1029e669bacdb6b88889ec1aa804fe717560e872dc44d049127af9aa155a8895c8a60 hiawatha.conf.sample"
diff --git a/testing/hiawatha/fix-mbedtls-underlinking.patch b/testing/hiawatha/fix-mbedtls-underlinking.patch
deleted file mode 100644
index bd2ec2f3c4..0000000000
--- a/testing/hiawatha/fix-mbedtls-underlinking.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./CMakeLists.txt.orig
-+++ ./CMakeLists.txt
-@@ -114,7 +114,7 @@
- #add_definitions(-DMBEDTLS_THREADING_PTHREAD -DMBEDTLS_THREADING_C)
- add_subdirectory(mbedtls)
- endif()
-- set(MBEDTLS_LIBRARY "mbedtls")
-+ set(MBEDTLS_LIBRARIES "mbedtls" "mbedx509" "mbedcrypto")
- endif()
-
- # Hiawatha
-@@ -144,8 +144,8 @@
- target_link_libraries(wigwam ${CRYPT_LIBRARY})
- target_link_libraries(hiawatha ${CRYPT_LIBRARY} pthread ${Z_LIBRARY})
- if(ENABLE_TLS)
-- target_link_libraries(hiawatha ${MBEDTLS_LIBRARY})
-- target_link_libraries(wigwam ${MBEDTLS_LIBRARY})
-+ target_link_libraries(hiawatha ${MBEDTLS_LIBRARIES})
-+ target_link_libraries(wigwam ${MBEDTLS_LIBRARIES})
- if(NOT USE_SYSTEM_MBEDTLS)
- set_target_properties(hiawatha PROPERTIES INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR}/hiawatha)
- set_target_properties(wigwam PROPERTIES INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR}/hiawatha)