aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hitch
diff options
context:
space:
mode:
authorRaphael Cohn <raphael.cohn@stormmq.com>2016-06-04 12:50:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-07-11 18:12:19 +0000
commit48d384baa36f1abe30c2e82a80113638a8b5a1a7 (patch)
treee57557475dc7c7be24f005eff9a8edae430edf63 /testing/hitch
parentf9ef7f0e935e31e66ed29671092f9c166e8ec0dc (diff)
downloadaports-48d384baa36f1abe30c2e82a80113638a8b5a1a7.tar.bz2
aports-48d384baa36f1abe30c2e82a80113638a8b5a1a7.tar.xz
testing/hitch: new aport
https://hitch-tls.org/ A TLS/SSL endpoint similar to stunnel
Diffstat (limited to 'testing/hitch')
-rw-r--r--testing/hitch/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/hitch/APKBUILD b/testing/hitch/APKBUILD
new file mode 100644
index 0000000000..ca7380f947
--- /dev/null
+++ b/testing/hitch/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Raphael Cohn <raphael.cohn@stormmq.com>
+# Maintainer: Raphael Cohn <raphael.cohn@stormmq.com>
+pkgname=hitch
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="hitch is a TLS / SSL endpoint like stunnel"
+url="https://hitch-tls.org/"
+arch="all"
+license="BSD"
+depends="libev"
+depends_dev=""
+makedepends="libev-dev openssl-dev automake autoconf py-docutils bison flex"
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/varnish/hitch/archive/hitch-1.2.0.tar.gz"
+
+builddir="$pkgname-$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ ./bootstrap || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ pwd
+ cd src/"$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="92378e514ae235755d9fade27e2d9f95 hitch-1.2.0.tar.gz"
+sha256sums="129c26f5bc7bf9ae3c3458af5dd3d9dc96007eab70cf603c9859355beea36b51 hitch-1.2.0.tar.gz"
+sha512sums="bf5014211bfa82240b3e850e4800534436ff41665a9422e9ed5acdbcbb01ba3b0e98c8c1fcb572edb8ea67e15c1169583ed7a04c49d2015a8b99f179c4718178 hitch-1.2.0.tar.gz"