aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hub/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-12 11:44:00 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-12 11:49:17 +0000
commit5c05a26cb633db747e07d2b6101a6e4295493405 (patch)
tree10d8f7f885e154e6a60f888292e32ce43791346f /testing/hub/APKBUILD
parent37c150666498a4b027ff4f20c8695ab8211e5010 (diff)
downloadaports-5c05a26cb633db747e07d2b6101a6e4295493405.tar.bz2
aports-5c05a26cb633db747e07d2b6101a6e4295493405.tar.xz
testing/hub: upgrade to 2.4.0 and take maintainership
Diffstat (limited to 'testing/hub/APKBUILD')
-rw-r--r--testing/hub/APKBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/testing/hub/APKBUILD b/testing/hub/APKBUILD
index 116bf5a659..b24be38627 100644
--- a/testing/hub/APKBUILD
+++ b/testing/hub/APKBUILD
@@ -1,16 +1,14 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Eivind Uggedal <eivind@uggedal.com>
-# Maintainer
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=hub
-pkgver=2.2.3
+pkgver=2.4.0
pkgrel=0
pkgdesc="Extends git with extra features for GitHub"
url="http://hub.github.com/"
arch="all"
license="MIT"
-depends=""
makedepends="go bash"
-install=""
options="!strip"
subpackages="
$pkgname-doc
@@ -19,14 +17,16 @@ subpackages="
source="$pkgname-$pkgver.tar.gz::https://github.com/github/hub/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
+
build() {
- cd "$builddir" && ./script/build
+ cd "$builddir"
+ ./script/build
}
package() {
cd "$builddir"
- install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
- install -D -m644 man/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+ install -Dm755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"
+ install -D -m644 share/man/man1/$pkgname.1.ronn "$pkgdir"/usr/share/man/man1/$pkgname.1
}
bashcomp() {
@@ -35,7 +35,7 @@ bashcomp() {
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
install -Dm644 "$builddir"/etc/hub.bash_completion.sh \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname || return 1
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
}
zshcomp() {
@@ -44,7 +44,7 @@ zshcomp() {
install_if="$pkgname=$pkgver-r$pkgrel zsh"
install -Dm644 "$builddir"/etc/$pkgname.zsh_completion \
- "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname || return 1
+ "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
}
-sha512sums="a255f7006fcf442d6ff1cb35fe3e9d37a1db2dd61125653b7b4713d3a41309a8f2a2076ac791101a46cb5bcd3d46ca33969f0e0817ef62ff3a57fc72f5acae82 hub-2.2.3.tar.gz"
+sha512sums="302a508b7353ed96f969d399d87cd395b5561490c41f46043969a49eaa997a63d2649b3f6f23a565f1b8c821f93c4db1b8c7104c85d0b08fc6d96f03e765f2f7 hub-2.4.0.tar.gz"