aboutsummaryrefslogtreecommitdiffstats
path: root/testing/icingaweb2-module-generictts
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-02-08 16:14:26 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-02-08 16:14:31 +0000
commit121c6018141f7503dd7c1b9a46910e4213839489 (patch)
treeb5e51deb99f4a2c874e8b5f3690cf33212ee9c45 /testing/icingaweb2-module-generictts
parent37f5f2e2c026458b138b8a3f74522471f7996c06 (diff)
downloadaports-121c6018141f7503dd7c1b9a46910e4213839489.tar.bz2
aports-121c6018141f7503dd7c1b9a46910e4213839489.tar.xz
testing/icingaweb2-module-generictts: new aport
Diffstat (limited to 'testing/icingaweb2-module-generictts')
-rw-r--r--testing/icingaweb2-module-generictts/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/icingaweb2-module-generictts/APKBUILD b/testing/icingaweb2-module-generictts/APKBUILD
new file mode 100644
index 0000000000..d063e0033e
--- /dev/null
+++ b/testing/icingaweb2-module-generictts/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=icingaweb2-module-generictts
+_module=${pkgname/*-/}
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="Generic ticket system integration into Icinga web 2"
+url="http://www.icinga.org"
+arch="noarch"
+license="GPL2"
+_php=php5
+depends="icingaweb2-module-director ${_php}-xml"
+pkggroups="icingaweb2"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir/etc/icingaweb2/modules/$_module"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ mkdir -p "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ cp -a application library public module.info run.php configuration.php \
+ "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ chgrp -R $pkggroups "$pkgdir/etc/icingaweb2/modules/$_module"
+ cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
+You need to fix /etc/icingaweb2/modules/$_module with the owner of the user of your webserver
+
+For nginx, as example:
+ # chown -R nginx /etc/icingaweb2/modules/$_module
+or
+ # chown -R nobody /etc/icingaweb2/modules/$_module
+
+For Apache:
+ # chown -R apache /etc/icingaweb2/modules/$_module
+
+For lighttpd:
+ # chown -R lighttpd /etc/icingaweb2/modules/$_module
+
+Remember to enable the module with:
+
+ # icingacli module enable $_module
+
+EOF
+
+}
+
+md5sums="119c1e7054fed8f9b5af038817819116 icingaweb2-module-generictts-2.0.0.tar.gz"
+sha256sums="7fcffc7125a89e9ea7a029fdb61ee341912b9b827a4aa373b4e39d7073102d02 icingaweb2-module-generictts-2.0.0.tar.gz"
+sha512sums="90ccb2d57e34b9322792806628836c36f34ac40a21ea218a2464d25446a17632acdf7a3f73ba79c9a55b8dd4a04269cc60d243e89b9f9bc0195ed1f4f0cf6c4b icingaweb2-module-generictts-2.0.0.tar.gz"