aboutsummaryrefslogtreecommitdiffstats
path: root/testing/icingaweb2-module-pnp
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-02-08 16:14:13 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-02-08 16:14:31 +0000
commit37f5f2e2c026458b138b8a3f74522471f7996c06 (patch)
treec542c3853eccefbced3ae356eca25de5a578b72e /testing/icingaweb2-module-pnp
parentba3ed9a280a79501c09ed543b1a8c7c02994996e (diff)
downloadaports-37f5f2e2c026458b138b8a3f74522471f7996c06.tar.bz2
aports-37f5f2e2c026458b138b8a3f74522471f7996c06.tar.xz
testing/icingaweb2-module-pnp: new aport
Diffstat (limited to 'testing/icingaweb2-module-pnp')
-rw-r--r--testing/icingaweb2-module-pnp/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/icingaweb2-module-pnp/APKBUILD b/testing/icingaweb2-module-pnp/APKBUILD
new file mode 100644
index 0000000000..db5ab33554
--- /dev/null
+++ b/testing/icingaweb2-module-pnp/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=icingaweb2-module-pnp
+_module=${pkgname/*-/}
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Integrate PNP graphs into Icinga Web 2 "
+url="http://www.icinga.org"
+arch="noarch"
+license="GPL2"
+_php=php5
+depends="icingaweb2-module-director ${_php}-xml"
+pkggroups="icingaweb2"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir/etc/icingaweb2/modules/$_module"
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+ mkdir -p "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ cp -a application library module.info run.php configuration.php \
+ "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
+ chgrp -R $pkggroups "$pkgdir/etc/icingaweb2/modules/$_module"
+ cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
+You need to fix /etc/icingaweb2/modules/$_module with the owner of the user of your webserver
+
+For nginx, as example:
+ # chown -R nginx /etc/icingaweb2/modules/$_module
+or
+ # chown -R nobody /etc/icingaweb2/modules/$_module
+
+For Apache:
+ # chown -R apache /etc/icingaweb2/modules/$_module
+
+For lighttpd:
+ # chown -R lighttpd /etc/icingaweb2/modules/$_module
+
+Remember to enable the module with:
+
+ # icingacli module enable $_module
+
+EOF
+
+}
+
+md5sums="aaa59111db247f001e5f26f7064b50b2 icingaweb2-module-pnp-1.0.1.tar.gz"
+sha256sums="956d2afe1dc3895994381baf40f3ac326ba1f771c84c86b54ba39c64b78483df icingaweb2-module-pnp-1.0.1.tar.gz"
+sha512sums="594a8d2a141bdf682fa37dc7b677a78f255dfa3d05071878a416b7426ed6355abc2a2864394e333a00c08aba8fd4f898e42c5a49ffeaf689a16de175f6ddb333 icingaweb2-module-pnp-1.0.1.tar.gz"