aboutsummaryrefslogtreecommitdiffstats
path: root/testing/imapfilter
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-09 12:44:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-10 12:04:49 +0000
commitf025cd1fcc30f1df71ee3031899d3f6a16528049 (patch)
tree439026f1c54a95c1a1483a6a8f0680fa29a2508b /testing/imapfilter
parent3ef9ae3376291f520b1bd6215a1f43588e130340 (diff)
downloadaports-f025cd1fcc30f1df71ee3031899d3f6a16528049.tar.bz2
aports-f025cd1fcc30f1df71ee3031899d3f6a16528049.tar.xz
testing/imapfilter: rebuild against libressl
Diffstat (limited to 'testing/imapfilter')
-rw-r--r--testing/imapfilter/APKBUILD19
-rw-r--r--testing/imapfilter/libressl.patch53
2 files changed, 65 insertions, 7 deletions
diff --git a/testing/imapfilter/APKBUILD b/testing/imapfilter/APKBUILD
index e6ac1de936..bc0e603d95 100644
--- a/testing/imapfilter/APKBUILD
+++ b/testing/imapfilter/APKBUILD
@@ -2,18 +2,20 @@
# Maintainer: Andrew Hills <ahills@ednos.net>
pkgname=imapfilter
pkgver=2.5.7
-pkgrel=1
+pkgrel=2
pkgdesc="Lua-based filtering for IMAP mailboxes"
url="https://github.com/lefcha/imapfilter"
arch="all"
license="MIT"
-depends="pcre openssl lua libcrypto1.0"
+depends=""
depends_dev=
-makedepends="$depends_dev lua-dev openssl-dev pcre-dev libc-dev"
+makedepends="$depends_dev lua-dev libressl-dev pcre-dev libc-dev"
install=
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/lefcha/$pkgname/archive/v${pkgver}.tar.gz
- io-flush.patch"
+ io-flush.patch
+ libressl.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
@@ -41,8 +43,11 @@ package() {
install
}
md5sums="5af01afcca4a24b46f113f36bc3eaef8 imapfilter-2.5.7.tar.gz
-c005e65cae202f8f6779380996d51ee1 io-flush.patch"
+c005e65cae202f8f6779380996d51ee1 io-flush.patch
+27ba5b28471fe3c401353d3a46b5caa3 libressl.patch"
sha256sums="c792d6a3a187cdc14fc38470837b45722a3750dabd2c6f71672806eeef79fad0 imapfilter-2.5.7.tar.gz
-14c49fd8ced2a0730a0b21e20e5b2149ad3a65eca55e258d591fef3f06befb59 io-flush.patch"
+14c49fd8ced2a0730a0b21e20e5b2149ad3a65eca55e258d591fef3f06befb59 io-flush.patch
+c57570be4d854615d9b466af594c10bda6e2819640b197e7ae183838cfb362ff libressl.patch"
sha512sums="9297e98812312fbf2c92aa5477bdfecb522048e45b4bc4922e312bd89a72b020a98f5547e3f0882ae665c24db21e6995eda839b762947adc48bc413ab0c882f1 imapfilter-2.5.7.tar.gz
-ab11ad7b52f0b56119e6da636bf4c53f09ca9f2fe8a7083fc9af9528ba0d67657b639283a3100868c919b3958c812ae7169d8879af4b7205f43207458e0b8073 io-flush.patch"
+ab11ad7b52f0b56119e6da636bf4c53f09ca9f2fe8a7083fc9af9528ba0d67657b639283a3100868c919b3958c812ae7169d8879af4b7205f43207458e0b8073 io-flush.patch
+416614d44f64627f9e3dbbf0b11972618dde5129dbfd494289b63db491b8c9b8c1fee44112237af88ea42bd9a803c0b7a64de16d33b81d3d775b237bcc6a8626 libressl.patch"
diff --git a/testing/imapfilter/libressl.patch b/testing/imapfilter/libressl.patch
new file mode 100644
index 0000000000..e8b0de6ced
--- /dev/null
+++ b/testing/imapfilter/libressl.patch
@@ -0,0 +1,53 @@
+--- a/src/imapfilter.c.orig 2014-11-17 00:36:40.000000000 +0000
++++ b/src/imapfilter.c 2015-12-27 11:04:14.643145411 +0000
+@@ -21,7 +21,10 @@
+
+ extern buffer ibuf, obuf, nbuf, cbuf;
+ extern regexp responses[];
+-extern SSL_CTX *ssl3ctx, *ssl23ctx, *tls1ctx;
++extern SSL_CTX *ssl23ctx, *tls1ctx;
++#ifndef OPENSSL_NO_SSL3_METHOD
++extern SSL_CTX *ssl3ctx;
++#endif
+ #if OPENSSL_VERSION_NUMBER >= 0x01000100fL
+ extern SSL_CTX *tls11ctx, *tls12ctx;
+ #endif
+@@ -51,7 +54,7 @@
+ opts.config = NULL;
+ opts.oneline = NULL;
+ opts.debug = NULL;
+- opts.truststore = "/etc/ssl/certs";
++ opts.truststore = "/etc/ssl/cert.pem";
+
+ env.home = NULL;
+ env.pathmax = -1;
+@@ -108,7 +111,9 @@
+
+ SSL_library_init();
+ SSL_load_error_strings();
++#ifndef OPENSSL_NO_SSL3_METHOD
+ ssl3ctx = SSL_CTX_new(SSLv3_client_method());
++#endif
+ ssl23ctx = SSL_CTX_new(SSLv23_client_method());
+ tls1ctx = SSL_CTX_new(TLSv1_client_method());
+ #if OPENSSL_VERSION_NUMBER >= 0x01000100fL
+@@ -116,7 +121,9 @@
+ tls12ctx = SSL_CTX_new(TLSv1_2_client_method());
+ #endif
+ if (exists_dir(opts.truststore)) {
++#ifndef OPENSSL_NO_SSL3_METHOD
+ SSL_CTX_load_verify_locations(ssl3ctx, NULL, opts.truststore);
++#endif
+ SSL_CTX_load_verify_locations(ssl23ctx, NULL, opts.truststore);
+ SSL_CTX_load_verify_locations(tls1ctx, NULL, opts.truststore);
+ #if OPENSSL_VERSION_NUMBER >= 0x01000100fL
+@@ -142,7 +149,9 @@
+ #endif
+ stop_lua();
+
++#ifndef OPENSSL_NO_SSL3_METHOD
+ SSL_CTX_free(ssl3ctx);
++#endif
+ SSL_CTX_free(ssl23ctx);
+ SSL_CTX_free(tls1ctx);
+ #if OPENSSL_VERSION_NUMBER >= 0x01000100fL