aboutsummaryrefslogtreecommitdiffstats
path: root/testing/iodine
diff options
context:
space:
mode:
authorGuy Taylor <thebigguy.co.uk@gmail.com>2016-12-01 22:51:41 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 06:36:44 +0000
commit8e042847c53a79281e53f13d6c560d366da16dee (patch)
tree562958f490ea281196bcc6b2539aef214d65fea3 /testing/iodine
parenteae64a38ef298888dd677021f7a32d881a0f9311 (diff)
downloadaports-8e042847c53a79281e53f13d6c560d366da16dee.tar.bz2
aports-8e042847c53a79281e53f13d6c560d366da16dee.tar.xz
testing/iodine: new aport
http://code.kryo.se/iodine/ IP over DNS tunnel
Diffstat (limited to 'testing/iodine')
-rw-r--r--testing/iodine/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/iodine/APKBUILD b/testing/iodine/APKBUILD
new file mode 100644
index 0000000000..b02974b2a5
--- /dev/null
+++ b/testing/iodine/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Guy Taylor <thebigguy.co.uk@gmail.com>
+# Maintainer:
+pkgname=iodine
+pkgver=0.7.0
+pkgrel=0
+pkgdesc="IP over DNS tunnel"
+url="http://code.kryo.se/iodine/"
+arch="all"
+license="ISC"
+depends=""
+makedepends="linux-headers"
+subpackages="$pkgname-doc"
+source="http://code.kryo.se/iodine/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ CFLAGS="$CLAGS -D__GLIBC__=1" make || return 1
+}
+
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" prefix="/usr" install
+}
+
+md5sums="fdbf3b81cd69caf5230d76a8b039fd99 iodine-0.7.0.tar.gz"
+sha256sums="ad2b40acf1421316ec15800dcde0f587ab31d7d6f891fa8b9967c4ded93c013e iodine-0.7.0.tar.gz"
+sha512sums="49fe4f0cf614d3400cbfdade84eb4f50430f8f92004f663a08acc1514e8ff342443a8c3f855828bbca1864a3fafe419b5256f8a80fc4024b364d4c8c953fc0ec iodine-0.7.0.tar.gz"