aboutsummaryrefslogtreecommitdiffstats
path: root/testing/iozone
diff options
context:
space:
mode:
authorOleg Titov <oleg@MacBook-Pro-Oleg.local>2019-04-28 16:05:51 -0500
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-02 04:47:32 +0000
commit318fb2e3df2f8f6a516048b9440f5a6621591c90 (patch)
tree7d5bdd1bb96f3e6a0cfe12ba2ed3e2edee8b63b5 /testing/iozone
parent3da9d4239461e853723b0198f19df3b5e5251d75 (diff)
downloadaports-318fb2e3df2f8f6a516048b9440f5a6621591c90.tar.bz2
aports-318fb2e3df2f8f6a516048b9440f5a6621591c90.tar.xz
testing/iozone: new aport
http://iozone.org IOzone filesystem benchmark
Diffstat (limited to 'testing/iozone')
-rw-r--r--testing/iozone/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/iozone/APKBUILD b/testing/iozone/APKBUILD
new file mode 100644
index 0000000000..3b18f937cb
--- /dev/null
+++ b/testing/iozone/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=iozone
+pkgver=3.487
+_pkgver=${pkgver//./_}
+pkgrel=0
+pkgdesc="IOzone filesystem benchmark."
+url="http://iozone.org"
+arch="all"
+license="custom"
+options="!check" # No test suite from upstream
+subpackages="$pkgname-doc"
+source="http://iozone.org/src/current/${pkgname}${_pkgver}.tar"
+builddir="$srcdir/${pkgname}${_pkgver}/"
+
+build() {
+ local target=
+ case "$CARCH" in
+ x86_64) target="linux-AMD64" ;;
+ x86) target="linux" ;;
+ aarch64) target="linux-arm" ;;
+ armv7) target="linux-arm" ;;
+ armhf) target="linux-arm" ;;
+ s390x) target="linux-S390X" ;;
+ ppc64le) target="linux-powerpc64" ;;
+ *) msg "Unable to determine architecture from (CARCH=$CARCH)" ; return 1 ;;
+ esac
+
+ cd "$builddir"/src/current/
+ make $target CFLAGS='-DHAVE_PREADV -DHAVE_PWRITEV'
+}
+
+package() {
+ install -m755 -D src/current/iozone \
+ "$pkgdir"/usr/bin/iozone
+
+ install -dm755 "$pkgdir"/usr/share/licenses/$pkgname/
+ sed -n '1,49p' "$builddir"/src/current/iozone.c > \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm644 "$builddir"/docs/iozone.1 \
+ "$pkgdir"/usr/share/man/man1/iozone.1
+}
+
+sha512sums="2f3a9d259ca531e45124e8ad55358706e2f9615f50fbf434e786b832622aa5f673dbed1b2706c6450c200e0af7f7374e40402e0b06ad116d5f2a0704a6156a1a iozone3_487.tar"