aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ipgrab
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-11-27 00:11:03 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:16 -0600
commitf52aea8509e2b6e794e1232ca0dfeace65e00569 (patch)
treef271808d4cc5f6b620226dd21c484850d88dfb7e /testing/ipgrab
parent7cdf3f9ea842a9d0720c6484a78891c358243a72 (diff)
downloadaports-f52aea8509e2b6e794e1232ca0dfeace65e00569.tar.bz2
aports-f52aea8509e2b6e794e1232ca0dfeace65e00569.tar.xz
Initial APKBUILD for ipgrab
Package description: This program reads and parses packets from the link layer through the transport layer, dumping explicit header information along the way. It is a lot like tcpdump from LBL except that I've made an effort to dump every relevant header field possible. The overall structure of the code is loosely based on tcpdump and I've lifted a few modules from the tcpdump distribution when necessary, rather than re-inventing the wheel. In particular, the address conversion hashing routines are pretty much lifted verbatim, as well as the TCP options section. Web: http://ipgrab.sourceforge.net/
Diffstat (limited to 'testing/ipgrab')
-rw-r--r--testing/ipgrab/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/ipgrab/APKBUILD b/testing/ipgrab/APKBUILD
new file mode 100644
index 0000000000..778fc1bee6
--- /dev/null
+++ b/testing/ipgrab/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=ipgrab
+pkgver=0.9.8
+pkgrel=0
+pkgdesc="A verbose packet sniffer for hosts"
+url="http://ipgrab.sourceforge.net/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/ipgrab/ipgrab-$pkgver.tar.gz"
+_builddir="$srcdir"/ipgrab-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure ÂÂÂ\
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="73404aeee6e8c07b6b7d260ffe80b692 ipgrab-0.9.8.tar.gz"