aboutsummaryrefslogtreecommitdiffstats
path: root/testing/jruby
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-05-03 19:28:46 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-04 09:26:39 +0000
commit3130cc432cd00a739a4cf328e4292acb6cf41c83 (patch)
treef69681d41c4ad28e8b79b587a26bc97c45e3a64f /testing/jruby
parentc8b2ee881993c24eb6191bf3a6ff383555178822 (diff)
downloadaports-3130cc432cd00a739a4cf328e4292acb6cf41c83.tar.bz2
aports-3130cc432cd00a739a4cf328e4292acb6cf41c83.tar.xz
testing/jruby: fix missing dependencies
Diffstat (limited to 'testing/jruby')
-rw-r--r--testing/jruby/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/testing/jruby/APKBUILD b/testing/jruby/APKBUILD
index 010355e16d..9359179f48 100644
--- a/testing/jruby/APKBUILD
+++ b/testing/jruby/APKBUILD
@@ -4,13 +4,13 @@
# so it's probably not much usable for regular users.
pkgname=jruby
pkgver=9.0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="An implementation of Ruby on the JVM"
url="http://jruby.org"
arch="noarch"
license="EPL GPL-2 LGPL-2.1 custom"
# libc6-compat: https://github.com/jnr/jnr-posix/issues/73
-depends="java-jffi-native>=1.2 libc6-compat>=1.1.12-r5 openjdk8-jre"
+depends="$pkgname-libs java-jffi-native>=1.2 libc6-compat>=1.1.12-r5 openjdk8-jre-base"
makedepends="openjdk8 zip"
subpackages="$pkgname-irb $pkgname-maven $pkgname-minitest $pkgname-rake
$pkgname-rdoc $pkgname-readline $pkgname-testunit $pkgname-libs
@@ -52,8 +52,6 @@ build() {
}
package() {
- depends="$pkgname-libs"
-
cd "$builddir"
install -m644 -D "$builddir"/lib/jruby.jar \