aboutsummaryrefslogtreecommitdiffstats
path: root/testing/js_of_ocaml
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-11 23:53:35 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-12 00:00:54 +0100
commitffe52ad52f7ce86ee3fc4d696ea544a8806dc372 (patch)
treeae3b41cb62884fe87a9cf96d93d9f12995931e1a /testing/js_of_ocaml
parent1b40b0dd822f492b3da892ce873cc224322c7f22 (diff)
downloadaports-ffe52ad52f7ce86ee3fc4d696ea544a8806dc372.tar.bz2
aports-ffe52ad52f7ce86ee3fc4d696ea544a8806dc372.tar.xz
testing/js_of_ocaml: build with yojson to enable --source-map
Diffstat (limited to 'testing/js_of_ocaml')
-rw-r--r--testing/js_of_ocaml/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/testing/js_of_ocaml/APKBUILD b/testing/js_of_ocaml/APKBUILD
index e477c86dcd..d2de771962 100644
--- a/testing/js_of_ocaml/APKBUILD
+++ b/testing/js_of_ocaml/APKBUILD
@@ -1,10 +1,9 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
# TODO: Verify declared dependencies.
-# TODO: Build with source-map support (needs yojson and base64)
pkgname=js_of_ocaml
pkgver=3.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="Compiler from OCaml to Javascript"
url="http://ocsigen.org/js_of_ocaml/"
arch="all !x86 !armhf !s390x" # limited by ocaml aport
@@ -20,10 +19,12 @@ makedepends="
bash
dune
ocaml
+ ocaml-biniou-dev
ocaml-camlp4-dev
ocaml-cmdliner-dev
ocaml-compiler-libs
ocaml-cppo-dev
+ ocaml-easy-format-dev
ocaml-findlib-dev
ocaml-lwt-dev
ocaml-migrate-parsetree-dev
@@ -36,6 +37,7 @@ makedepends="
ocaml-result-dev
ocaml-tyxml-dev
ocaml-uchar-dev
+ ocaml-yojson-dev
ocamlbuild
opam
"
@@ -101,7 +103,7 @@ camlp4() {
compiler() {
pkgdesc="$pkgdesc (compiler)"
- depends="ocaml ocaml-cmdliner ocaml-cppo ocaml-findlib"
+ depends="ocaml ocaml-cmdliner ocaml-cppo ocaml-findlib ocaml-yojson"
_subpackage