aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kcompletion
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 09:30:43 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 15:47:29 +0000
commit0586ffd5c24fb150bb88fae979c1bd60ad01a351 (patch)
treee11bdf6f184f8942fee2b3aeec70238862901d13 /testing/kcompletion
parent0d0651be2f51481b2b97035bda898933e153386e (diff)
downloadaports-0586ffd5c24fb150bb88fae979c1bd60ad01a351.tar.bz2
aports-0586ffd5c24fb150bb88fae979c1bd60ad01a351.tar.xz
testing/kcompletion: use xvfb-run to run tests that need X11
Closes GH-8396
Diffstat (limited to 'testing/kcompletion')
-rw-r--r--testing/kcompletion/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/kcompletion/APKBUILD b/testing/kcompletion/APKBUILD
index e9f2f15617..e032f344a5 100644
--- a/testing/kcompletion/APKBUILD
+++ b/testing/kcompletion/APKBUILD
@@ -9,6 +9,7 @@ url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="kwidgetsaddons-dev kconfig-dev"
makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
+checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
@@ -22,8 +23,7 @@ build() {
}
check() {
- # kcompletioncoretest, klineedit_unittest and kcombobox_unittest require X11 to be running
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(kcompletioncore|klineedit_unit|kcombobox_unit)test'
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {