aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kexec-tools
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-10-14 22:28:59 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-11-02 23:13:33 +0100
commit68274d71509cb7b39b1b3629c1a1b0bf98be1fd3 (patch)
tree2b2caf92e602da1dc897920ca0582f509a8b4fe7 /testing/kexec-tools
parentae2a3af84f47dc250e1e4862c2a16330228027cc (diff)
downloadaports-68274d71509cb7b39b1b3629c1a1b0bf98be1fd3.tar.bz2
aports-68274d71509cb7b39b1b3629c1a1b0bf98be1fd3.tar.xz
testing/kexec-tools: upgrade to 2.0.20
remove aarch64-build-fix.patch, not needed add fix-build-on-Alpine-linux.patch to fix build on x86 arch change url to current development url
Diffstat (limited to 'testing/kexec-tools')
-rw-r--r--testing/kexec-tools/APKBUILD13
-rw-r--r--testing/kexec-tools/aarch64-build-fix.patch12
-rw-r--r--testing/kexec-tools/fix-build-on-Alpine-linux.patch28
3 files changed, 35 insertions, 18 deletions
diff --git a/testing/kexec-tools/APKBUILD b/testing/kexec-tools/APKBUILD
index 558b12fa1e..81e755fe94 100644
--- a/testing/kexec-tools/APKBUILD
+++ b/testing/kexec-tools/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Duncan Guthrie <dguthrie@posteo.net>
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=kexec-tools
-pkgver=2.0.16
-pkgrel=1
+pkgver=2.0.20
+pkgrel=0
pkgdesc="Directly boot into a new kernel over a currently running one"
-url="https://kernel.org/pub/linux/utils/kernel/kexec/"
+url="https://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git/"
arch="all"
license="GPL-2.0"
depends="xz zlib"
@@ -12,7 +12,8 @@ makedepends="zlib-dev xz-dev linux-headers"
subpackages="$pkgname-doc"
source="https://www.kernel.org/pub/linux/utils/kernel/kexec/$pkgname-$pkgver.tar.xz
kexec-tools-2.0.16-fix-config-sub.patch
- aarch64-build-fix.patch"
+ fix-build-on-Alpine-linux.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
options="!check"
@@ -35,6 +36,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f2f06e7702fef20c8d7d6aabe1b264e2e2689e5c38cc00dbc2186dd7fa0479edb2dc9e307dd2ad7f03db47015e966e577f11576172604ef01c1bcca471fe2c24 kexec-tools-2.0.16.tar.xz
+sha512sums="3112b6202c1030705c53e3f65a2b58aec14d65333a35aad681d48b9f2bd1c51a2e05c985a1e5e867ab02f8a9c97708483d9d225619db7c6993676f1a242e2d99 kexec-tools-2.0.20.tar.xz
3c87540309dceda4c074d5822fd1a5d709ad533baed91dfd77aa64ebfe3850fc099c4b3d2bcc887c81ae53dc5940d17ccf34be25609beb37ed5ef7ed75862d43 kexec-tools-2.0.16-fix-config-sub.patch
-77c2c33c28b85640646836da1709e898e1d94b92e0a83217664c64cb6606e10471235a396f30f8cae1315d67804851fc9cf8f201bc0b9e1d1f1f8344cd0e448d aarch64-build-fix.patch"
+228166102bfc48f81c04f3b13fbf29d6edf2e66918a967f243c8d2652f40c27af565f1db6b1a58783bd12d67184a70e6b00b1ab82e0f0d195dd51009260c3329 fix-build-on-Alpine-linux.patch"
diff --git a/testing/kexec-tools/aarch64-build-fix.patch b/testing/kexec-tools/aarch64-build-fix.patch
deleted file mode 100644
index 5f9f915725..0000000000
--- a/testing/kexec-tools/aarch64-build-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/purgatory/arch/arm64/Makefile b/purgatory/arch/arm64/Makefile
-index 636abea..9aad157 100644
---- a/purgatory/arch/arm64/Makefile
-+++ b/purgatory/arch/arm64/Makefile
-@@ -3,6 +3,7 @@ arm64_PURGATORY_EXTRA_CFLAGS = \
- -mcmodel=large \
- -fno-stack-protector \
- -fno-asynchronous-unwind-tables \
-+ -fno-PIC \
- -Wundef \
- -Werror-implicit-function-declaration \
- -Wdeclaration-after-statement \
diff --git a/testing/kexec-tools/fix-build-on-Alpine-linux.patch b/testing/kexec-tools/fix-build-on-Alpine-linux.patch
new file mode 100644
index 0000000000..ee96f05727
--- /dev/null
+++ b/testing/kexec-tools/fix-build-on-Alpine-linux.patch
@@ -0,0 +1,28 @@
+From d390f1f873fa42fa5791ba48f9acf0f41da33632 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Milan=20P=2E=20Stani=C4=87?= <mps@arvanta.net>
+Date: Sat, 19 Oct 2019 17:10:16 +0000
+Subject: [PATCH] kexec/arch/i386/kexec-x86.c: fix build on Alpine linux x86
+ arch
+
+---
+ kexec/arch/i386/kexec-x86.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/kexec/arch/i386/kexec-x86.c b/kexec/arch/i386/kexec-x86.c
+index 444cb69..6001e76 100644
+--- a/kexec/arch/i386/kexec-x86.c
++++ b/kexec/arch/i386/kexec-x86.c
+@@ -36,8 +36,8 @@
+ struct file_type file_type[] = {
+ { "multiboot-x86", multiboot_x86_probe, multiboot_x86_load,
+ multiboot_x86_usage },
+- { "multiboot2-x86", multiboot2_x86_probe, multiboot2_x86_load,
+- multiboot2_x86_usage },
++ { "multiboot2-x86", multiboot_x86_probe, multiboot_x86_load,
++ multiboot_x86_usage },
+ { "elf-x86", elf_x86_probe, elf_x86_load, elf_x86_usage },
+ { "bzImage", bzImage_probe, bzImage_load, bzImage_usage },
+ { "beoboot-x86", beoboot_probe, beoboot_load, beoboot_usage },
+--
+2.23.0
+