aboutsummaryrefslogtreecommitdiffstats
path: root/testing/keystone
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-02-22 12:19:03 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-02-22 12:19:03 +0100
commit60bfa2663be057ecb4fb2d28abf58a99099587ee (patch)
treebbcc0bac5e054ecac3ac59518a9a7bddc2abedf1 /testing/keystone
parent49040d4a31d5ab2906761a5e74c147fed8c67f88 (diff)
downloadaports-60bfa2663be057ecb4fb2d28abf58a99099587ee.tar.bz2
aports-60bfa2663be057ecb4fb2d28abf58a99099587ee.tar.xz
testing/keystone: fix build with None build type
Diffstat (limited to 'testing/keystone')
-rw-r--r--testing/keystone/APKBUILD6
-rw-r--r--testing/keystone/none-build-type.patch15
2 files changed, 19 insertions, 2 deletions
diff --git a/testing/keystone/APKBUILD b/testing/keystone/APKBUILD
index b81cf6c886..aefbe42157 100644
--- a/testing/keystone/APKBUILD
+++ b/testing/keystone/APKBUILD
@@ -11,7 +11,8 @@ depends=""
makedepends="cmake python3-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-python"
-source="$pkgname-$pkgver.tar.gz::https://github.com/keystone-engine/$pkgname/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/keystone-engine/$pkgname/archive/$pkgver.tar.gz
+ none-build-type.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -47,4 +48,5 @@ python() {
python3 setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="3bd9c3793d5862a0a8628b52da381625e62445f661dbd5ed715723e7d9db01ce3f9586e5ca0a5cc71e8ceb6c912050f5c28e3ccd540e72c8abcfd2f0d1bbae17 keystone-0.9.1.tar.gz"
+sha512sums="3bd9c3793d5862a0a8628b52da381625e62445f661dbd5ed715723e7d9db01ce3f9586e5ca0a5cc71e8ceb6c912050f5c28e3ccd540e72c8abcfd2f0d1bbae17 keystone-0.9.1.tar.gz
+0a101a1398eec32e7cb2e5e201d8f822ec44916e7c40ed59caf89482102b536e1ec9a23bc9321bc14a4ac56db11669b4c7aa5b297942af25cf8ccf21d9483037 none-build-type.patch"
diff --git a/testing/keystone/none-build-type.patch b/testing/keystone/none-build-type.patch
new file mode 100644
index 0000000000..d568628377
--- /dev/null
+++ b/testing/keystone/none-build-type.patch
@@ -0,0 +1,15 @@
+The build system includes its own check for available CMake build types.
+This check is incorrect as it doesn't include the None build type.
+
+diff -upr keystone-0.9.1.orig/llvm/CMakeLists.txt keystone-0.9.1/llvm/CMakeLists.txt
+--- keystone-0.9.1.orig/llvm/CMakeLists.txt 2020-02-22 12:17:15.681580953 +0100
++++ keystone-0.9.1/llvm/CMakeLists.txt 2020-02-22 12:18:20.949144210 +0100
+@@ -142,7 +142,7 @@ include(CPack)
+ string(TOUPPER "${CMAKE_BUILD_TYPE}" uppercase_CMAKE_BUILD_TYPE)
+
+ if (CMAKE_BUILD_TYPE AND
+- NOT uppercase_CMAKE_BUILD_TYPE MATCHES "^(DEBUG|RELEASE|RELWITHDEBINFO|MINSIZEREL)$")
++ NOT uppercase_CMAKE_BUILD_TYPE MATCHES "^(NONE|DEBUG|RELEASE|RELWITHDEBINFO|MINSIZEREL)$")
+ message(FATAL_ERROR "Invalid value for CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}")
+ endif()
+