aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kio-fuse
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-25 11:47:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-25 12:40:03 +0100
commit19b21278ec0c44fda97da2ab6bf11f7145aec2a1 (patch)
tree6bdd269a87cf8dd898c95bfb9a6f387b4f40eaf1 /testing/kio-fuse
parentc064679f7dc88263b0f2f612ee2302d22934776f (diff)
downloadaports-19b21278ec0c44fda97da2ab6bf11f7145aec2a1.tar.bz2
aports-19b21278ec0c44fda97da2ab6bf11f7145aec2a1.tar.xz
testing/kio-fuse: new aport
Diffstat (limited to 'testing/kio-fuse')
-rw-r--r--testing/kio-fuse/APKBUILD45
-rw-r--r--testing/kio-fuse/kio-fuse.post-install5
-rw-r--r--testing/kio-fuse/modules-load.conf1
3 files changed, 51 insertions, 0 deletions
diff --git a/testing/kio-fuse/APKBUILD b/testing/kio-fuse/APKBUILD
new file mode 100644
index 0000000000..921a7a287c
--- /dev/null
+++ b/testing/kio-fuse/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kio-fuse
+pkgver=4.90.0
+pkgrel=0
+arch="all"
+url="https://kde.org/"
+pkgdesc="FUSE interface for KIO"
+license="GPL-3.0-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev kcoreaddons-dev kdbusaddons-dev kio-dev fuse3-dev"
+checkdepends="dbus"
+source="https://download.kde.org/unstable/kio-fuse/$pkgver/kio-fuse-$pkgver.tar.xz
+ modules-load.conf"
+install="$pkgname.post-install"
+options="!check" # Only test is broken
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+
+ install -Dm644 "$srcdir"/modules-load.conf "$pkgdir"/etc/modules-load.d/kio-fuse.conf
+}
+
+sha512sums="524b9f6559c7f30823a5e2ffddd65a36ea569bbdba493563fcf9e0a038cd897c27cdf0450a932d7307dec663e898c2f693f6ee17a679df8d4ddf566ffcab73ce kio-fuse-4.90.0.tar.xz
+57d23d2778556eafc3035e6be575bf95b4032f123b35f2b1657eff5e7496de253173edc657f90531ee58e25673f4f27a5cd1cc76b14a038edb244f104a231771 modules-load.conf"
diff --git a/testing/kio-fuse/kio-fuse.post-install b/testing/kio-fuse/kio-fuse.post-install
new file mode 100644
index 0000000000..62c42f3a99
--- /dev/null
+++ b/testing/kio-fuse/kio-fuse.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+modprobe fuse
+
+exit 0
diff --git a/testing/kio-fuse/modules-load.conf b/testing/kio-fuse/modules-load.conf
new file mode 100644
index 0000000000..a517c488f3
--- /dev/null
+++ b/testing/kio-fuse/modules-load.conf
@@ -0,0 +1 @@
+fuse